summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-09 10:30:21 -0400
committerKyle Keen2015-08-09 10:30:21 -0400
commit43914a24225b3dbec7c47d4699d341f131710a09 (patch)
tree36feeea365403d1a415ae7b4ed0e18c7a246f1c9
downloadaur-43914a24225b3dbec7c47d4699d341f131710a09.tar.gz
aur3 recovery
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--hexcurse-alloca.patch13
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..480ab5b5088d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hexcurse
+ pkgdesc = Versatile ncurses-based hex editor.
+ pkgver = 1.55
+ pkgrel = 3
+ url = http://directory.fsf.org/project/HexCurse/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses>=5.6-7
+ options = !makeflags
+ source = http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/hexcurse-1.55.tar.gz
+ source = hexcurse-alloca.patch
+ md5sums = c9f9485490300b5111aa429eabfef789
+ md5sums = fb7723bff0411392fe410839f6105e4f
+
+pkgname = hexcurse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ba2f5402d56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: SpepS <dreamspepser at yahoo dot it>
+# Contributor: eric <eric@archlinux.org>
+
+pkgname=hexcurse
+pkgver=1.55
+pkgrel=3
+pkgdesc="Versatile ncurses-based hex editor."
+arch=('i686' 'x86_64')
+url="http://directory.fsf.org/project/HexCurse/"
+license=('GPL')
+depends=('ncurses>=5.6-7')
+options=('!makeflags')
+source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz"
+ "hexcurse-alloca.patch")
+#source=("http://www.sourcefiles.org/Editors/Hex/$pkgname-$pkgver.tar.gz")
+md5sums=('c9f9485490300b5111aa429eabfef789'
+ 'fb7723bff0411392fe410839f6105e4f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p0 < ../hexcurse-alloca.patch
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/hexcurse-alloca.patch b/hexcurse-alloca.patch
new file mode 100644
index 000000000000..e12e8737fe73
--- /dev/null
+++ b/hexcurse-alloca.patch
@@ -0,0 +1,13 @@
+--- src/getopt.c 2002-03-21 17:55:54.000000000 +0100
++++ /root/getopt.c 2004-08-09 12:52:39.592951560 +0200
+@@ -36,8 +36,8 @@
+ * enables hexcurse to be compiled with SGI's proprietary compiler */
+ #ifdef _SGIAPI
+ #include <alloca.h>
+-#else
+-char *alloca ();
++//#else
++//char *alloca ();
+ #endif
+ #define __alloca alloca
+ /* end of modification */