summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:55:24 +0200
committerM0Rf302015-06-17 15:55:24 +0200
commit4392bfdd886c0776449143fd3e0b0f1ec737906f (patch)
tree48cf08d831621ecc24d9b9fb3089c822cbc25655
downloadaur-4392bfdd886c0776449143fd3e0b0f1ec737906f.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
-rw-r--r--libreengineering.sh3
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4939a4e4bbce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libreengineering
+ pkgdesc = A suite of instrumentation, electrical, mechanical, process engineering calculation and design programs and other tools.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = http://libreeng.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python2
+ depends = python2-pyqt4
+ depends = python2-pyenchant
+ depends = python2-pysqlite
+ depends = python2-sqlalchemy
+ optdepends = hunspell: required for Translit only
+ source = http://downloads.sourceforge.net/project/libreeng/LibreEngineering-0.5.0.tar.bz2
+ source = libreengineering.sh
+ md5sums = 75fc0abf74619c0343b571287bd9f4a9
+ md5sums = 4598d1adaf2629c19e319e48316c77fb
+
+pkgname = libreengineering
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a06349a75e92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: M0Rf30
+
+pkgname=libreengineering
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='A suite of instrumentation, electrical, mechanical, process engineering calculation and design programs and other tools.'
+url='http://libreeng.sourceforge.net/'
+license=('GPL3')
+arch=('i686' 'x86_64')
+depends=('python2' 'python2-pyqt4' 'python2-pyenchant' 'python2-pysqlite' 'python2-sqlalchemy')
+optdepends=('hunspell: required for Translit only')
+source=("http://downloads.sourceforge.net/project/libreeng/LibreEngineering-${pkgver}.tar.bz2"
+ 'libreengineering.sh')
+
+package() {
+ cd ${srcdir}
+ mkdir $pkgdir/opt
+ cp -r LibreEngineering-${pkgver} $pkgdir/opt/libreeng
+ cd $pkgdir/opt/libreeng
+ python2 -m compileall .
+ cd ${srcdir}
+ install -Dm755 libreengineering.sh $pkgdir/usr/bin/libreengineering
+ chmod +x $pkgdir/usr/bin/libreengineering
+}
+
+md5sums=('75fc0abf74619c0343b571287bd9f4a9'
+ '4598d1adaf2629c19e319e48316c77fb')
diff --git a/libreengineering.sh b/libreengineering.sh
new file mode 100644
index 000000000000..a1fbf60c4098
--- /dev/null
+++ b/libreengineering.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/libreeng
+python2 libreengineering.pyw