summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-01-08 16:42:10 +0100
committerCarsten Teibes2014-01-08 16:42:10 +0100
commit439807ab2cdff9dfaa4a2ed248f81daf978385f6 (patch)
treeaa3ed1b9439b7a035a37ed615cb7eb27669d88f5
parent94c8e614e745c3c7017b148f5c6f928eda18b07b (diff)
downloadaur-439807ab2cdff9dfaa4a2ed248f81daf978385f6.tar.gz
Cleanup
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
-rw-r--r--opendune.desktop2
-rw-r--r--opendune.install10
-rw-r--r--opendune.sh2
5 files changed, 27 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 327e8100d5b6..e6c6c15c20fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = opendune-git
pkgdesc = Open source re-creation of the popular game Dune II
- pkgver = 0.7.6615ef9
+ pkgver = 0.7.88d5666
pkgrel = 1
- url = https://github.com/OpenDUNE/OpenDUNE
+ url = http://opendune.org
install = opendune.install
arch = i686
arch = x86_64
@@ -13,21 +13,14 @@ pkgbase = opendune-git
optdepends = timidity++: midi music support
provides = opendune
conflicts = opendune
- source = git://github.com/OpenDUNE/OpenDUNE.git
+ source = opendune::git+https://github.com/OpenDUNE/OpenDUNE.git
source = opendune.sh
source = opendune.desktop
source = opendune.png
- source = opendune.install
- md5sums = SKIP
- md5sums = acaaaca7340f9b5d8c1d7ccc001ddf57
- md5sums = 2ff96b1efe864b1426f950005625af35
- md5sums = 4a6fef6e5bdde8ee7f038554bc5ed93b
- md5sums = c997170cd2667920a5988a22b4b1e40f
sha256sums = SKIP
- sha256sums = a62b0f37084654f3524ca4502c3864f90ef199e01755f5f18f162fa348f2fd2e
- sha256sums = f2a41122e61587bb07528764fda1fb116ed00d41bab49d324bdc893607c3c029
+ sha256sums = 56a2802f74b2bce644a34a7c2519307ec5925dbc111a1f132f6a19ef4b5e00f0
+ sha256sums = b80429ce421d6f781b1ef0c7c50293cf5970225e8de0fd6e379290d1fd91d4d7
sha256sums = 89c9cbf76b3f7ac62bf39235a64b191ee4b3bd437f88161b6757b6ec44e8888b
- sha256sums = b672aca4ac3bc7d6f4578f2793c02dda5903e4d7cfc8b52a3e3ddc51bfe2816a
pkgname = opendune-git
diff --git a/PKGBUILD b/PKGBUILD
index 2f68a7241f51..88424925543e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,52 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
_pkgbase=opendune
pkgname=$_pkgbase-git
-_gitname=OpenDUNE
-pkgver=0.7.6615ef9
+pkgver=0.7.88d5666
pkgrel=1
pkgdesc="Open source re-creation of the popular game Dune II"
arch=('i686' 'x86_64')
-url="https://github.com/OpenDUNE/OpenDUNE"
+url="http://opendune.org"
license=('GPL2')
depends=('sdl' 'alsa-lib')
makedepends=('git')
optdepends=('timidity++: midi music support')
conflicts=('opendune')
provides=('opendune')
-install="$_pkgbase.install"
-source=("git://github.com/OpenDUNE/OpenDUNE.git"
+install=$_pkgbase.install
+source=($_pkgbase::"git+https://github.com/OpenDUNE/OpenDUNE.git"
"$_pkgbase.sh"
"$_pkgbase.desktop"
- "$_pkgbase.png"
- "$_pkgbase.install")
-md5sums=('SKIP'
- 'acaaaca7340f9b5d8c1d7ccc001ddf57'
- '2ff96b1efe864b1426f950005625af35'
- '4a6fef6e5bdde8ee7f038554bc5ed93b'
- 'c997170cd2667920a5988a22b4b1e40f')
+ "$_pkgbase.png")
sha256sums=('SKIP'
- 'a62b0f37084654f3524ca4502c3864f90ef199e01755f5f18f162fa348f2fd2e'
- 'f2a41122e61587bb07528764fda1fb116ed00d41bab49d324bdc893607c3c029'
- '89c9cbf76b3f7ac62bf39235a64b191ee4b3bd437f88161b6757b6ec44e8888b'
- 'b672aca4ac3bc7d6f4578f2793c02dda5903e4d7cfc8b52a3e3ddc51bfe2816a')
+ '56a2802f74b2bce644a34a7c2519307ec5925dbc111a1f132f6a19ef4b5e00f0'
+ 'b80429ce421d6f781b1ef0c7c50293cf5970225e8de0fd6e379290d1fd91d4d7'
+ '89c9cbf76b3f7ac62bf39235a64b191ee4b3bd437f88161b6757b6ec44e8888b')
pkgver() {
- cd $_gitname
+ cd $_pkgbase
# get last annotated tag from packed refs
echo $(tail -n 2 .git/packed-refs | head -n 1 | cut -d "/" -f 3).$(git rev-parse --short master)
}
build() {
- cd $_gitname
+ cd $_pkgbase
./configure --prefix-dir=/opt/opendune
-
make
}
package() {
- cd $_gitname
+ cd $_pkgbase
- make INSTALL_ICON_DIR="$pkgdir/opt/$_pkgbase" INSTALL_BINARY_DIR="$pkgdir/opt/$_pkgbase" INSTALL_DOC_DIR="$pkgdir/opt/$_pkgbase/doc" install
+ make INSTALL_ICON_DIR="$pkgdir"/opt/$_pkgbase \
+ INSTALL_BINARY_DIR="$pkgdir"/opt/$_pkgbase \
+ INSTALL_DOC_DIR="$pkgdir"/opt/$_pkgbase/doc install
# install binary, icon and desktop files
- install -Dm755 "$srcdir/$_pkgbase.sh" "$pkgdir/usr/bin/$_pkgbase"
- install -Dm644 "$srcdir/$_gitname/bin/data/put_dune2_here.txt" "$pkgdir/opt/$_pkgbase/data/put_dune2_here.txt"
- install -Dm644 "$srcdir/$_pkgbase.png" "$pkgdir/usr/share/pixmaps/$_pkgbase.png"
- install -Dm644 "$srcdir/$_pkgbase.desktop" "$pkgdir/usr/share/applications/$_pkgbase.desktop"
+ install -Dm755 ../$_pkgbase.sh "$pkgdir"/usr/bin/$_pkgbase
+ install -Dm644 bin/data/put_dune2_here.txt "$pkgdir"/opt/$_pkgbase/data/put_dune2_here.txt
+ install -Dm644 ../$_pkgbase.png "$pkgdir"/usr/share/pixmaps/$_pkgbase.png
+ install -Dm644 ../$_pkgbase.desktop "$pkgdir"/usr/share/applications/$_pkgbase.desktop
}
diff --git a/opendune.desktop b/opendune.desktop
index d9992938615a..66d47d107487 100644
--- a/opendune.desktop
+++ b/opendune.desktop
@@ -3,6 +3,6 @@ Name=OpenDUNE
Exec=opendune
Icon=opendune
Type=Application
-Comment=Open source re-creation of the popular game "Dune II"
+Comment=Open source re-creation of "Dune II"
Categories=Game;
Terminal=false
diff --git a/opendune.install b/opendune.install
index 9edaaaee1210..947e89baf6d2 100644
--- a/opendune.install
+++ b/opendune.install
@@ -1,16 +1,8 @@
post_install() {
- # updates for our .desktop file
- update-desktop-database -q
-
echo "Remember you need to be in the audio group and start timidity, eg 'timidity -iA' for music support."
}
post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- # updates for our .desktop file
- update-desktop-database -q
+ post_install
}
diff --git a/opendune.sh b/opendune.sh
index 060e5271b2f1..00b9f9ecb76e 100644
--- a/opendune.sh
+++ b/opendune.sh
@@ -20,6 +20,6 @@ if [ -f $HOME/.opendune/data/dune.pak ]; then
else
- echo "Please place Dune II data files in \"$HOME/.opendune/data\"."
+ echo "Please place Dune II data files in \"~/.opendune/data\"."
fi