summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-01-25 23:39:22 +0800
committerq234rty2023-01-25 23:41:20 +0800
commit439fd0a9334fb0ec6232f7e160e578e33f332a0c (patch)
tree2462e19243a0fd1ef4a3c726c8a4c765a66ccb79
parentd60326cb1cfad60133db8f3a91d88c47d7d421e0 (diff)
downloadaur-439fd0a9334fb0ec6232f7e160e578e33f332a0c.tar.gz
Put everything into /opt
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc8b8b129b8a..dfacc9b95e4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waydroid-script-git
pkgdesc = Python Script to add OpenGapps, Magisk, libhoudini translation library and libndk translation library to waydroid
- pkgver = r23.9a3b849
+ pkgver = r87.2f4f056
pkgrel = 1
url = https://github.com/casualsnek/waydroid_script
arch = any
@@ -8,6 +8,7 @@ pkgbase = waydroid-script-git
makedepends = git
depends = python-requests
depends = python-tqdm
+ depends = dbus-python
depends = lzip
depends = sqlite
depends = waydroid
diff --git a/PKGBUILD b/PKGBUILD
index 0d49cbf7e9e9..36ffc812df37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: Sam L. Yes <samlukeyes123 at gmail dot com>
+# Maintainer: q234 rty <q23456yuiop at gmail dot com>
+# Contributor: Sam L. Yes <samlukeyes123 at gmail dot com>
_repo_name=waydroid_script
-_script=waydroid_extras.py
+_script=main.py
pkgname=waydroid-script-git
-pkgver=r23.9a3b849
+_pkgname=waydroid-script
+pkgver=r87.2f4f056
pkgrel=1
pkgdesc="Python Script to add OpenGapps, Magisk, libhoudini translation library and libndk translation library to waydroid"
arch=('any')
url="https://github.com/casualsnek/$_repo_name"
license=('GPL3')
makedepends=('git')
-depends=('python-requests' 'python-tqdm' 'lzip' 'sqlite' 'waydroid')
+depends=('python-requests' 'python-tqdm' 'dbus-python' 'lzip' 'sqlite' 'waydroid')
optdepends=()
provides=('waydroid-script')
conflicts=('waydroid-script')
@@ -29,6 +31,10 @@ pkgver() {
package() {
cd ${srcdir}/$_repo_name
+ install -d ${pkgdir}/opt/${_pkgname}
+ cp -r * ${pkgdir}/opt/${_pkgname}/
+ rm ${pkgdir}/opt/${_pkgname}/{'LICENSE','README.md','requirements.txt'} #LICENSE is already indicated
+ chmod +x ${pkgdir}/opt/${_pkgname}/$_script
install -d ${pkgdir}/usr/bin
- install -m755 $_script ${pkgdir}/usr/bin/waydroid-extras
+ ln -s /opt/${_pkgname}/$_script ${pkgdir}/usr/bin/waydroid-extras
}