summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2022-06-30 12:03:02 +0800
committerYour Name2022-06-30 12:03:02 +0800
commit43bef9af8b79a941db44846739aeae10f4fe856e (patch)
treebc808a92faa8e6be7981f6119c237a50c081ada5
parent9ba8985dcabe23abee6f12e95742193dcf519464 (diff)
downloadaur-43bef9af8b79a941db44846739aeae10f4fe856e.tar.gz
Use electron13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--baidunetdisk-wrapper.sh2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c90601e14608..0917c0695314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = baidunetdisk-electron
pkgdesc = Baidu Net Disk - a cloud storage client (Linux Version). Run with system electron.
pkgver = 4.10.5
- pkgrel = 1
+ pkgrel = 2
url = https://pan.baidu.com
arch = x86_64
license = custom
- depends = electron11
+ depends = electron13
provides = baidunetdisk
conflicts = baidunetdisk
options = !strip
source = 0001-baidunetdisk-bin-desktop-file.patch
source = baidunetdisk-wrapper.sh
sha256sums = 17bda6036e07916971257f25731130fb1b760b80798fa13273db39268ab9f28c
- sha256sums = 14e82c2e285ee28e1d38538f8a434d3a1301621225a3130667d875688a5e430f
+ sha256sums = 37837db36ac35fc0bfe6479325573497f60774f5b53b3ae2cdcd625991077654
source_x86_64 = baidunetdisk-electron-4.10.5.deb::http://wppkg.baidupcs.com/issue/netdisk/Linuxguanjia/4.10.5/baidunetdisk_4.10.5_amd64.deb
sha256sums_x86_64 = d9761b3c99a1740405e261580fc0ab990c243de7ac54b3a8a831145777dc9bb9
diff --git a/PKGBUILD b/PKGBUILD
index c69a277fbdf7..75a502862da4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
_pkgname=baidunetdisk
pkgname=baidunetdisk-electron
pkgver=4.10.5
-pkgrel=1
+pkgrel=2
#_mainver=${pkgver%.*}
pkgdesc="Baidu Net Disk - a cloud storage client (Linux Version). Run with system electron."
arch=('x86_64')
-depends=('electron11')
+depends=('electron13')
provides=("baidunetdisk")
conflicts=("baidunetdisk")
url="https://pan.baidu.com"
@@ -23,7 +23,7 @@ source=("0001-baidunetdisk-bin-desktop-file.patch"
source_x86_64=("${pkgname}-${pkgver}.deb::http://wppkg.baidupcs.com/issue/netdisk/Linuxguanjia/${pkgver}/baidunetdisk_${pkgver}_amd64.deb")
sha256sums=('17bda6036e07916971257f25731130fb1b760b80798fa13273db39268ab9f28c'
- '14e82c2e285ee28e1d38538f8a434d3a1301621225a3130667d875688a5e430f')
+ '37837db36ac35fc0bfe6479325573497f60774f5b53b3ae2cdcd625991077654')
sha256sums_x86_64=('d9761b3c99a1740405e261580fc0ab990c243de7ac54b3a8a831145777dc9bb9')
prepare() {
@@ -47,7 +47,7 @@ package() {
# remove unnecessary libs
cd "${pkgdir}/usr/lib/${_pkgname}"
- rm -rf baidunetdisk swiftshader chrome_100_percent.pak libEGL.so locales v8_context_snapshot.bin chrome_200_percent.pak libffmpeg.so libvk_swiftshader.so vk_swiftshader_icd.json chrome-sandbox libGLESv2.so libvulkan.so resources.pak icudtl.dat snapshot_blob.bin baiduNetdiskContext.conf baidunetdisk.svg baidunetdiskv.desktop resources/8bb88996964c4e3202fecaaa5605af03 resources/default.db resources/dir.icns resources/resource.db
+ rm -rf baidunetdisk swiftshader chrome_100_percent.pak libEGL.so locales v8_context_snapshot.bin chrome_200_percent.pak libffmpeg.so libvk_swiftshader.so vk_swiftshader_icd.json chrome-sandbox libGLESv2.so libvulkan.so resources.pak icudtl.dat snapshot_blob.bin baiduNetdiskContext.conf baidunetdisk.svg baidunetdiskv.desktop baidunetdisk.desktop resources/8bb88996964c4e3202fecaaa5605af03 resources/default.db resources/dir.icns resources/resource.db
# install license
diff --git a/baidunetdisk-wrapper.sh b/baidunetdisk-wrapper.sh
index 9b21416291b4..b285142c3b2e 100644
--- a/baidunetdisk-wrapper.sh
+++ b/baidunetdisk-wrapper.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-LD_PRELOAD="/usr/lib/baidunetdisk/libbrowserengine.so:/usr/lib/baidunetdisk/libkernel.so" exec electron11 /usr/lib/baidunetdisk/resources/app.asar "$@"
+LD_PRELOAD="/usr/lib/baidunetdisk/libbrowserengine.so:/usr/lib/baidunetdisk/libkernel.so" exec electron13 /usr/lib/baidunetdisk/resources/app.asar "$@"