summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2024-03-14 15:35:42 -0400
committergraysky2024-03-14 15:35:42 -0400
commit43f6d953ea3afd0abfe15dedc3e4d203b1b645e1 (patch)
tree07f4f196b0e6dd26f275addfb2b4bf4274f72cf6
parent58bd7796083e11dc6f3df6d14ec45b505779784a (diff)
downloadaur-43f6d953ea3afd0abfe15dedc3e4d203b1b645e1.tar.gz
Update to 30.19.13-1
-rw-r--r--.SRCINFO12
-rw-r--r--0001-makefile-fix-build-for-Arch-Linux.patch42
-rw-r--r--PKGBUILD14
3 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91167f7db4dc..64a2bc0473ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mprime
pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
- pkgver = 30.8.15
- pkgrel = 2
- epoch = 2
+ pkgver = 30.19.13
+ pkgrel = 1
+ epoch = 1
url = http://www.mersenne.org
arch = x86_64
license = custom
@@ -11,9 +11,9 @@ pkgbase = mprime
depends = hwloc
depends = boost-libs
conflicts = mprime-bin
- source = https://www.mersenne.org/download/software/v30/30.8/p95v308b15.source.zip
+ source = https://www.mersenne.org/download/software//v30/30.19/p95v3019b13.source.zip
source = 0001-makefile-fix-build-for-Arch-Linux.patch
- b2sums = 9ec5da2125b62630da84cad91b2293403fbdc9d86eb3b03a3b943256417f816cdfff1d8c5af9f6e7604c5cc628c65c13161437e19468985b7b037562fc1050da
- b2sums = 8b6f218b70d89d76b555e0955d480e7112279dd87f8f6101dd10eaf9b8de846d9fd469a7ba0ba7685ed68aa40fff240e0c7a9002380e4482ddf44d69b285587c
+ b2sums = d0dbc36269585321a4cef44298b6438ab75f255a5ada5f35aea1218173da5ff04a8593d70cccc3776f45c415b9c1ed4152f3dda23710758ae21be66a94524bf3
+ b2sums = 630b854d53db06980dddb5b4489cb6192cba9205839ced97397ef2cff5c7cc1905443f3bf37608233b84d2a84634dc38a46a40d4239d844cba424fa3a34de15b
pkgname = mprime
diff --git a/0001-makefile-fix-build-for-Arch-Linux.patch b/0001-makefile-fix-build-for-Arch-Linux.patch
index 5e3e2a481965..e63dd496900c 100644
--- a/0001-makefile-fix-build-for-Arch-Linux.patch
+++ b/0001-makefile-fix-build-for-Arch-Linux.patch
@@ -1,41 +1,41 @@
-From da7641d4be383e1170ab39bc162480cb1836591e Mon Sep 17 00:00:00 2001
+From 7542155615e1af7f4ea45df986659c41085441e5 Mon Sep 17 00:00:00 2001
From: graysky <therealgraysky AT proton DOT me>
-Date: Sat, 24 Sep 2022 14:12:44 -0400
+Date: Thu, 14 Mar 2024 15:33:41 -0400
Subject: [PATCH] makefile: fix build for Arch Linux
Fix up for Arch Linux build. Thanks to Prime95 for the tip around polymult.a lib[1].
1. https://www.mersenneforum.org/showthread.php?t=28094
-
---
- linux64/makefile | 10 ++++++----
- 1 file changed, 6 insertions(+), 4 deletions(-)
+ linux64/makefile | 11 +++++++----
+ 1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/linux64/makefile b/linux64/makefile
-index 420801f..a319fc1 100644
+index 61d130e..639c1bd 100644
--- a/linux64/makefile
+++ b/linux64/makefile
-@@ -18,15 +18,17 @@
- # LFLAGS = -Wl,-M
- # LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
-
-+ALFLAGS = -I.. -I../gwnum -march=x86-64 -DX86_64 -O2 -Wno-unused-result -march=x86-64 -DPORT=8
-+
+@@ -20,14 +20,17 @@
+ # LIBS = ../gwnum/gwnum.a -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
+
CC = gcc
-CFLAGS = -I.. -I../gwnum -I/usr/local/include -std=gnu99 -DX86_64 -Wno-unused-result -O2 -DPORT=8
+CFLAGS = ${ALFLAGS}
-
+
CPP = g++
-CPPFLAGS = -I.. -I../gwnum -I../../boost_1_76_0 -DX86_64 -std=c++11 -O2 -DPORT=8
+CPPFLAGS = ${ALFLAGS} -std=c++11
-
--LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
++
+LFLAGS = -Wl,-M
- #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld ../gwnum/polymult.a -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
--LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld ../gwnum/polymult.a -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
-+LIBS= ../gwnum/gwnum.a ../gwnum/gwnum.ld ../gwnum/polymult.a -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
-
+
+-LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
+ #LIBS = ../gwnum/gwnum.a ../gwnum/polymult.a -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+-LIBS = ../gwnum/gwnum.a ../gwnum/polymult.a -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
++LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld ../gwnum/polymult.a -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
++
++ALFLAGS = -I.. -I../gwnum -march=x86-64 -DX86_64 -O2 -Wno-unused-result -march=x86-64 -DPORT=8
+
FACTOROBJ = factor64.o
LINUXOBJS = prime.o menu.o cJSON.o ecm.o exponentiate.o pair.o pm1prob.o
---
-2.37.3
+--
+2.44.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 43cc940b62a0..3bda3ca1ee76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
# Contributer: TryA - https://bbs.archlinux.org/viewtopic.php?id=114996
pkgname=mprime
-pkgver=30.8.15
-epoch=2
-_pkgver=308b15
-pkgrel=2
+pkgver=30.19.13
+epoch=1
+_pkgver=3019b13
+pkgrel=1
pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
arch=(x86_64)
url="http://www.mersenne.org"
@@ -14,10 +14,10 @@ license=('custom')
depends=(curl hwloc boost-libs)
makedepends=(boost)
conflicts=(mprime-bin)
-source=("https://www.mersenne.org/download/software/v30/30.8/p95v${_pkgver}.source.zip"
+source=("https://www.mersenne.org/download/software//v${pkgver%%.*}/${pkgver%.*}/p95v${_pkgver}.source.zip"
0001-makefile-fix-build-for-Arch-Linux.patch)
-b2sums=('9ec5da2125b62630da84cad91b2293403fbdc9d86eb3b03a3b943256417f816cdfff1d8c5af9f6e7604c5cc628c65c13161437e19468985b7b037562fc1050da'
- '8b6f218b70d89d76b555e0955d480e7112279dd87f8f6101dd10eaf9b8de846d9fd469a7ba0ba7685ed68aa40fff240e0c7a9002380e4482ddf44d69b285587c')
+b2sums=('d0dbc36269585321a4cef44298b6438ab75f255a5ada5f35aea1218173da5ff04a8593d70cccc3776f45c415b9c1ed4152f3dda23710758ae21be66a94524bf3'
+ '630b854d53db06980dddb5b4489cb6192cba9205839ced97397ef2cff5c7cc1905443f3bf37608233b84d2a84634dc38a46a40d4239d844cba424fa3a34de15b')
prepare () {
patch -Np1 -i 0001-makefile-fix-build-for-Arch-Linux.patch