summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-11-28 20:38:08 -0500
committeréclairevoyant2023-11-28 20:38:08 -0500
commit43ffa45f1e8806c10f1cef840b5fad59149defa3 (patch)
treef1d75d7fca59bf1ec63e587324ff092df545f923
parent56bfa53deffcd7202e9c68b5359fdfc2e6ad7e90 (diff)
downloadaur-43ffa45f1e8806c10f1cef840b5fad59149defa3.tar.gz
zrythm: upgpkg 1.0.0-beta.4.13.31
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 875ffbd398b8..7c16571c5c7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zrythm
pkgdesc = Highly automated and intuitive digital audio workstation
- pkgver = 1.0.0.beta.4.12.34
- pkgrel = 2
+ pkgver = 1.0.0.beta.4.13.31
+ pkgrel = 1
url = https://www.zrythm.org
arch = x86_64
arch = i686
@@ -46,14 +46,16 @@ pkgbase = zrythm
depends = sratom
depends = vamp-plugin-sdk
depends = xxhash
+ depends = pcre
+ depends = zix
optdepends = realtime-privileges: allow memory locking
options = debug
- source = https://www.zrythm.org/releases/zrythm-1.0.0-beta.4.12.34.tar.xz
- source = https://www.zrythm.org/releases/zrythm-1.0.0-beta.4.12.34.tar.xz.asc
+ source = https://www.zrythm.org/releases/zrythm-1.0.0-beta.4.13.31.tar.xz
+ source = https://www.zrythm.org/releases/zrythm-1.0.0-beta.4.13.31.tar.xz.asc
source = git+https://github.com/drobilla/zix.git
source = 0001-gcc13-fixes.patch
validpgpkeys = 48132384AD3DF7D86E254B83022EAE42313D70F3
- sha256sums = f1c6193b884d42478c05bb200ffcee122eec317efbdecf1ffcc2174d0b502b9b
+ sha256sums = bf503d4091d7d4ad06d1980cb9cff1fd3de18d1a268cc81578468cf0b2c30965
sha256sums = SKIP
sha256sums = SKIP
sha256sums = bb93eea519020e491f85c38ab3901ac530bbf747c4e7acc3aaea39f402091653
diff --git a/PKGBUILD b/PKGBUILD
index 15bdfb9c181b..76b6d4f144f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Alexandros Theodotou <alex at zrythm dot org>
pkgname=zrythm
-_pkgver=1.0.0-beta.4.12.34
+_pkgver=1.0.0-beta.4.13.31
pkgver="${_pkgver/-/.}"
-pkgrel=2
+pkgrel=1
pkgdesc='Highly automated and intuitive digital audio workstation'
arch=(x86_64 i686)
url="https://www.zrythm.org"
@@ -45,6 +45,8 @@ depends=(
sratom
vamp-plugin-sdk
xxhash
+ pcre
+ zix
)
makedepends=(git meson cmake ruby-sass help2man sassc)
optdepends=('realtime-privileges: allow memory locking')
@@ -52,7 +54,7 @@ options=('debug')
source=("https://www.zrythm.org/releases/$pkgname-$_pkgver.tar.xz"{,.asc}
"git+https://github.com/drobilla/zix.git"
0001-gcc13-fixes.patch)
-sha256sums=('f1c6193b884d42478c05bb200ffcee122eec317efbdecf1ffcc2174d0b502b9b'
+sha256sums=('bf503d4091d7d4ad06d1980cb9cff1fd3de18d1a268cc81578468cf0b2c30965'
'SKIP'
'SKIP'
'bb93eea519020e491f85c38ab3901ac530bbf747c4e7acc3aaea39f402091653')
@@ -88,4 +90,6 @@ package() {
CHANGELOG.md README.md THANKS TRANSLATORS \
-t "$pkgdir/usr/share/doc/$pkgname/"
meson install -C build --destdir="$pkgdir"
+
+ rm -rf "$pkgdir"{/usr/include/zix-0/,/usr/lib/pkgconfig/zix-0.pc}
}