summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLancia2022-10-26 15:46:56 +0330
committerLancia2022-10-26 15:46:56 +0330
commit440a2cdfae70823a0cfb044e458f8353fc6ca2e1 (patch)
tree7efc92403054251b27b63b5282b8d8ccc3d787ee
parent01d30c258c54bc207c8df526a852e6a9d0d1e51f (diff)
downloadaur-440a2cdfae70823a0cfb044e458f8353fc6ca2e1.tar.gz
Added makedepends() to PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD3
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0fd60158e32..395b3a1fbc3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = herbe
- pkgdesc = Daemon-less notifications without D-Bus. Minimal and lightweight.
+ pkgdesc = Daemon-less notifications without D-Bus
pkgver = 1.0.0
pkgrel = 1
- epoch = 1
- url = https://github.com/trizen/herbe
- arch = i686
+ url = https://github.com/dudik/herbe
arch = x86_64
license = MIT
+ makedepends = make
depends = libx11
+ conflicts = herbe
+ conflicts = herbe-git
source = herbe-1.0.0.tar.gz::https://github.com/dudik/herbe/archive/1.0.0.tar.gz
sha256sums = 78e454159050c86e030fb5a6cf997ac914345210cdf5a4ca4d7600c5296b7f76
pkgname = herbe
-
diff --git a/PKGBUILD b/PKGBUILD
index c71837a287c8..86fa63d08350 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@ arch=('x86_64')
url='https://github.com/dudik/herbe'
license=('MIT')
depends=('libx11')
+makedepends=('make')
conflicts=('herbe' 'herbe-git')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dudik/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('78e454159050c86e030fb5a6cf997ac914345210cdf5a4ca4d7600c5296b7f76')
@@ -18,5 +19,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make PREFIX='/usr' DESTDIR="${pkgdir}" install
+ make PREFIX='/usr' DESTDIR="$pkgdir/" install
}