summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2021-01-09 23:51:22 +1000
committergameslayer2021-01-09 23:51:22 +1000
commit446b5b69f6a2c45e7e85a8d5dfcd74567bd61356 (patch)
tree308922e793968290578e39e3c25b899b8625896b
parent0581629c2749bfdb17d55dda44882475f6a5b427 (diff)
downloadaur-446b5b69f6a2c45e7e85a8d5dfcd74567bd61356.tar.gz
Pkgbuild fixes
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1aaec8efbacd..b4900a6eb74f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ depends=('nss' 'gtk3' 'libxss')
makedepends=('npm' 'git' 'unzip')
provides=("${pkgname%}")
conflicts=("gamerworld-bin")
-source=('git+https://gitlab.com/gamerworld/application.git#branch=Stable')
+source=('git+https://gitlab.com/gamerworld/application.git')
sha256sums=('SKIP')
pkgver() {
@@ -22,21 +22,21 @@ build() {
cd "$srcdir/application"
npm --cache "$srcdir/npm-cache" i electron@11.0.4 jquery electron-packager
./node_modules/.bin/electron-packager .
- for dir in $_pkgname-linux-*/ ; do mv "${dir}" "$_pkgname" ;done
- rm -rf "$srcdir/$pkgname/$_pkgname/resources/app/node_modules"
+ for dir in GamerWorld-linux-*/ ; do mv "${dir}" "GamerWorld" ;done
+ rm -rf "$srcdir/application/GamerWorld/resources/app/node_modules"
}
package() {
- cd "$srcdir/application/$_pkgname"
- install -dm755 "$pkgdir/opt/$_pkgname"
- cp -r ./ "$pkgdir/opt/$_pkgname"
+ cd "$srcdir/application/GamerWorld"
+ install -dm755 "$pkgdir/opt/GamerWorld"
+ cp -r ./ "$pkgdir/opt/GamerWorld"
# Link to binary
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/$_pkgname/$_pkgname" "$pkgdir/usr/bin/${pkgname%}"
+ ln -s "/opt/$_pkgname/GamerWorld" "$pkgdir/usr/bin/GamerWorld"
# Desktop Entry
- install -Dm644 "$srcdir/application/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
- sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 "$srcdir/application/GamerWorld.desktop" \
+ "$pkgdir/usr/share/applications/GamerWorld.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/GamerWorld.desktop"
}