summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkitsunyan2018-06-12 03:29:46 +0300
committerkitsunyan2018-06-12 03:29:46 +0300
commit4488ea4aea1928f0d990c2a5ff21f9ae0dbe4670 (patch)
tree47e5e61410737ded3ef6d59d966f516fc9d1e4a6
parentcce9a6aff9419394a5bdabfece7aedbc247930b4 (diff)
downloadaur-4488ea4aea1928f0d990c2a5ff21f9ae0dbe4670.tar.gz
upgpkg: pakku 0.13-1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Specify-refspec-when-git-fetch-is-used.patch72
-rw-r--r--PKGBUILD15
3 files changed, 8 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7f8d1d629d1..6341255dbf62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pakku
pkgdesc = Pacman wrapper with AUR support
- pkgver = 0.12
- pkgrel = 3
+ pkgver = 0.13
+ pkgrel = 1
url = https://github.com/kitsunyan/pakku
arch = x86_64
license = GPL3
@@ -9,10 +9,8 @@ pkgbase = pakku
depends = libcurl.so
depends = git
backup = etc/pakku.conf
- source = https://github.com/kitsunyan/pakku/releases/download/v0.12/pakku-0.12.tar.xz
- source = 0001-Specify-refspec-when-git-fetch-is-used.patch
- sha256sums = 73dc0da6bb36a9aa211b2e562d08d6cc60ab37ed527348f5d075df7aeac0e35c
- sha256sums = 4987262977ab82fb86a3c02c6c8388c01d6744a0f4bedb794be2bbce23b99748
+ source = https://github.com/kitsunyan/pakku/releases/download/v0.13/pakku-0.13.tar.xz
+ sha256sums = 18bddc6e4936c71e41d867e7aec9f6c9b906aca883b26275b7e1f153b08b78b7
pkgname = pakku
diff --git a/0001-Specify-refspec-when-git-fetch-is-used.patch b/0001-Specify-refspec-when-git-fetch-is-used.patch
deleted file mode 100644
index 670239e63638..000000000000
--- a/0001-Specify-refspec-when-git-fetch-is-used.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 5b5aa7c3968a4e36763edeb7d50b105a9248b39e Mon Sep 17 00:00:00 2001
-From: kitsunyan <`echo a2l0c3VueWFuQGFpcm1haWwuY2MK | base64 -d`>
-Date: Sun, 20 May 2018 20:08:41 +0300
-Subject: [PATCH] Specify refspec when git fetch is used
-
----
- src/common.nim | 20 ++++++++++++--------
- 1 file changed, 12 insertions(+), 8 deletions(-)
-
-diff --git a/src/common.nim b/src/common.nim
-index ca6d8c9..8518ded 100644
---- a/src/common.nim
-+++ b/src/common.nim
-@@ -448,8 +448,8 @@ proc reloadPkgInfos*(config: Config, path: string, pkgInfos: seq[PackageInfo]):
- template bareFullName*(bareKind: BareKind, bareName: string): string =
- $bareKind & "-" & bareName & ".git"
-
--proc cloneBareRepo(config: Config, bareKind: BareKind, bareName: string, url: string,
-- dropPrivileges: bool): Option[string] =
-+proc cloneBareRepo(config: Config, bareKind: BareKind, bareName: string,
-+ url: string, branchOption: Option[string], dropPrivileges: bool): Option[string] =
- let fullName = bareFullName(bareKind, bareName)
- let cachePath = config.userCache(dropPrivileges).cache(CacheKind.repositories)
- let repoPath = repoPath(cachePath, fullName)
-@@ -457,9 +457,12 @@ proc cloneBareRepo(config: Config, bareKind: BareKind, bareName: string, url: st
- if forkWait(() => (block:
- if not dropPrivileges or dropPrivileges():
- if existsDir(repoPath):
-- execResult(gitCmd, "-C", repoPath, "fetch", "-q", "--no-tags")
-+ let branch = branchOption.get("master")
-+ execResult(gitCmd, "-C", repoPath, "fetch", "-q", "--no-tags",
-+ "origin", branch & ":" & branch)
- else:
-- execResult(gitCmd, "-C", cachePath, "clone", "-q", "--bare", "--no-tags", url, fullName)
-+ execResult(gitCmd, "-C", cachePath, "clone", "-q", "--bare", "--no-tags",
-+ url, fullName)
- else:
- quit(1))) == 0:
- some(repoPath)
-@@ -474,7 +477,7 @@ proc cloneBareRepos*(config: Config, bareKind: BareKind, gitRepos: seq[GitRepo],
- else:
- let bare = gitRepos
- .filter(t => t.bareName.isSome)
-- .map(r => (r.bareName.unsafeGet, r.url))
-+ .map(r => (r.bareName.unsafeGet, r.url, r.branch))
- .deduplicate
-
- proc cloneNext(index: int, messages: List[string]): seq[string] =
-@@ -483,8 +486,8 @@ proc cloneBareRepos*(config: Config, bareKind: BareKind, gitRepos: seq[GitRepo],
- if index >= bare.len:
- toSeq(messages.reversed.items)
- else:
-- let (bareName, url) = bare[index]
-- let repoPath = cloneBareRepo(config, bareKind, bareName, url, dropPrivileges)
-+ let (bareName, url, branch) = bare[index]
-+ let repoPath = cloneBareRepo(config, bareKind, bareName, url, branch, dropPrivileges)
- if repoPath.isSome:
- cloneNext(index + 1, messages)
- else:
-@@ -644,7 +647,8 @@ proc cloneAurRepo*(config: Config, base: string, gitUrl: string,
- let cloneBareCode = forkWait(() => (block:
- if not dropPrivileges or dropPrivileges():
- if existsDir(bareRepoPath):
-- execResult(gitCmd, "-C", bareRepoPath, "fetch", "-q", "--no-tags")
-+ execResult(gitCmd, "-C", bareRepoPath, "fetch", "-q", "--no-tags",
-+ "origin", "master:master")
- else:
- execResult(gitCmd, "-C", cachePath, "clone", "-q", "--bare", "--no-tags",
- gitUrl, "--single-branch", fullName)
---
-2.17.0
-
diff --git a/PKGBUILD b/PKGBUILD
index b3a4b1dd8a25..a1e5603e6259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: kitsunyan <`echo a2l0c3VueWFuQGFpcm1haWwuY2MK | base64 -d`>
pkgname=pakku
-pkgver=0.12
-pkgrel=3
+pkgver=0.13
+pkgrel=1
pkgdesc='Pacman wrapper with AUR support'
arch=('x86_64')
url="https://github.com/kitsunyan/$pkgname"
@@ -10,15 +10,8 @@ license=('GPL3')
depends=('libcurl.so' 'git')
makedepends=('nim')
backup=('etc/pakku.conf')
-source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz"
- '0001-Specify-refspec-when-git-fetch-is-used.patch')
-sha256sums=('73dc0da6bb36a9aa211b2e562d08d6cc60ab37ed527348f5d075df7aeac0e35c'
- '4987262977ab82fb86a3c02c6c8388c01d6744a0f4bedb794be2bbce23b99748')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -i '../0001-Specify-refspec-when-git-fetch-is-used.patch'
-}
+source=("$url/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz")
+sha256sums=('18bddc6e4936c71e41d867e7aec9f6c9b906aca883b26275b7e1f153b08b78b7')
build() {
local addargs=()