summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-05-18 14:47:12 +0200
committerMartin Diehl2023-05-18 14:47:30 +0200
commit449911f7382bdef558c1e09d7b41e993ea6d1ae6 (patch)
tree8f5976b2e07e050be2ccfa1191734b3472a97bbb
parent22a510003de4562d958e120d1fbde36f2cdc6ed6 (diff)
downloadaur-449911f7382bdef558c1e09d7b41e993ea6d1ae6.tar.gz
14.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--compiler-errors.patch48
3 files changed, 39 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e272ff70ef69..042efff41e11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = trilinos
pkgdesc = algorithms for the solution of large-scale scientific problems
- pkgver = 13.4.1
- pkgrel = 2
+ pkgver = 14.0.0
+ pkgrel = 1
url = http://trilinos.org
arch = x86_64
license = LGPL3
@@ -21,9 +21,9 @@ pkgbase = trilinos
depends = hdf5-openmpi
provides = trilinos-sacado
provides = zoltan
- source = https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-13-4-1.tar.gz
+ source = https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-14-0-0.tar.gz
source = compiler-errors.patch
- sha256sums = 5465cbff3de7ef4ac7d40eeff9d99342c00d9d20eee0a5f64f0a523093f5f1b3
- sha256sums = a255f689d3a65187635a7dea2862b7c323c6efbc65501069bfe0cea7669d12a3
+ sha256sums = 054d2fabdf70fce0dfaeb20eed265bd7894045d3e00c3d1ddb72d1c77c339ca1
+ sha256sums = 09546864a36ec83cfbedb29c97ead05778b4da370a84185565973f28f49f2880
pkgname = trilinos
diff --git a/PKGBUILD b/PKGBUILD
index 67ae98385c4e..4713a54315a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
# Contributor: Simon Pintarelli <simon.pintarelli@gmail.com>
# Contributor: Feng Wang <wanng.fenng@gmail.com>
pkgname=trilinos
-pkgver=13.4.1
+pkgver=14.0.0
_pkgver=${pkgver//./-}
-pkgrel=2
+pkgrel=1
pkgdesc="algorithms for the solution of large-scale scientific problems"
arch=('x86_64')
url="http://trilinos.org"
@@ -18,8 +18,8 @@ provides=('trilinos-sacado' 'zoltan')
checkdepends=('cmake')
source=("https://github.com/trilinos/Trilinos/archive/refs/tags/trilinos-release-$_pkgver.tar.gz"
'compiler-errors.patch')
-sha256sums=('5465cbff3de7ef4ac7d40eeff9d99342c00d9d20eee0a5f64f0a523093f5f1b3'
- 'a255f689d3a65187635a7dea2862b7c323c6efbc65501069bfe0cea7669d12a3')
+sha256sums=('054d2fabdf70fce0dfaeb20eed265bd7894045d3e00c3d1ddb72d1c77c339ca1'
+ '09546864a36ec83cfbedb29c97ead05778b4da370a84185565973f28f49f2880')
prepare() {
patch -d Trilinos-trilinos-release-"$_pkgver" -p1 -i ../compiler-errors.patch
@@ -34,7 +34,9 @@ build() {
-DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
-DTrilinos_ENABLE_PyTrilinos:BOOL=OFF \
-DTrilinos_ENABLE_Gtest:BOOL=OFF \
- -DTrilinos_ENABLE_TESTS=OFF \
+ -DTrilinos_ENABLE_TESTS:BOOL=OFF \
+ -DTrilinos_ENABLE_TrilinosFrameworkTests:BOOL=OFF \
+ -DTrilinos_ENABLE_TrilinosATDMConfigTests:BOOL=OFF \
-DTPL_ENABLE_gtest:BOOL=OFF \
-DTPL_ENABLE_MPI:BOOL=ON \
-DTPL_ENABLE_HDF5:BOOL=ON \
diff --git a/compiler-errors.patch b/compiler-errors.patch
index c8e8cc2eadfe..3da154ac0e0c 100644
--- a/compiler-errors.patch
+++ b/compiler-errors.patch
@@ -1,28 +1,34 @@
-diff --color -ruN Trilinos-trilinos-release-13-4-0.orig/packages/krino/cmake/Dependencies.cmake Trilinos-trilinos-release-13-4-0.patch/packages/krino/cmake/Dependencies.cmake
---- Trilinos-trilinos-release-13-4-0.orig/packages/krino/cmake/Dependencies.cmake 2022-07-26 10:21:25.533252070 +0200
-+++ Trilinos-trilinos-release-13-4-0.patch/packages/krino/cmake/Dependencies.cmake 2022-07-26 10:22:45.580487344 +0200
+diff --color -urt Trilinos-trilinos-release-14-0-0.orig/packages/krino/cmake/Dependencies.cmake Trilinos-trilinos-release-14-0-0.new/packages/krino/cmake/Dependencies.cmake
+--- Trilinos-trilinos-release-14-0-0.orig/packages/krino/cmake/Dependencies.cmake 2023-05-18 08:34:11.085906271 +0200
++++ Trilinos-trilinos-release-14-0-0.new/packages/krino/cmake/Dependencies.cmake 2023-05-18 08:29:48.930168370 +0200
@@ -1,6 +1,6 @@
--SET(LIB_REQUIRED_DEP_PACKAGES SEACASIoss SEACASExodus SEACASAprepro STKBalance STKMath STKIO STKSearch STKTopology STKUtil STKTools STKEmend Percept Intrepid)
-+SET(LIB_REQUIRED_DEP_PACKAGES SEACASIoss SEACASExodus SEACASAprepro STKBalance STKMath STKIO STKSearch STKTopology STKUtil STKTools STKEmend Percept Intrepid STKUnit_test_utils)
+ SET(LIB_REQUIRED_DEP_PACKAGES SEACASIoss SEACASExodus SEACASAprepro STKBalance STKMath STKIO STKSearch STKTopology STKUtil STKTools STKEmend Percept Intrepid)
SET(LIB_OPTIONAL_DEP_PACKAGES)
-SET(TEST_REQUIRED_DEP_PACKAGES Gtest STKUnit_test_utils)
+SET(TEST_REQUIRED_DEP_PACKAGES Gtest)
SET(TEST_OPTIONAL_DEP_PACKAGES)
SET(LIB_REQUIRED_DEP_TPLS Boost)
- SET(LIB_OPTIONAL_DEP_TPLS MPI yaml-cpp)
-diff --color -ruN Trilinos-trilinos-release-13-4-0.orig/packages/seacas/libraries/exodus/src/ex_utils.c Trilinos-trilinos-release-13-4-0.patch/packages/seacas/libraries/exodus/src/ex_utils.c
---- Trilinos-trilinos-release-13-4-0.orig/packages/seacas/libraries/exodus/src/ex_utils.c 2022-07-26 10:21:25.809920802 +0200
-+++ Trilinos-trilinos-release-13-4-0.patch/packages/seacas/libraries/exodus/src/ex_utils.c 2022-07-26 11:54:27.865751226 +0200
-@@ -1742,11 +1742,10 @@
- */
+ SET(LIB_OPTIONAL_DEP_TPLS MPI ParMETIS yaml-cpp)
+diff --color -urt Trilinos-trilinos-release-14-0-0.orig/packages/krino/krino/CMakeLists.txt Trilinos-trilinos-release-14-0-0.new/packages/krino/krino/CMakeLists.txt
+--- Trilinos-trilinos-release-14-0-0.orig/packages/krino/krino/CMakeLists.txt 2023-05-18 08:34:11.085906271 +0200
++++ Trilinos-trilinos-release-14-0-0.new/packages/krino/krino/CMakeLists.txt 2023-05-18 08:35:25.202277721 +0200
+@@ -4,7 +4,6 @@
+ add_subdirectory(region)
+ add_subdirectory(rebalance_utils)
+ add_subdirectory(parser)
+-add_subdirectory(unit_tests)
- /* const int NC_SZIP_EC = 4; */ /* Selects entropy coding method for szip. */
-- const int NC_SZIP_NN = 32; /* Selects nearest neighbor coding method for szip. */
- /* Even and between 4 and 32; typical values are 8, 10, 16, 32 */
- const int SZIP_PIXELS_PER_BLOCK =
- file->compression_level == 0 ? 32 : file->compression_level;
-- nc_def_var_szip(exoid, varid, NC_SZIP_NN, SZIP_PIXELS_PER_BLOCK);
-+ nc_def_var_szip(exoid, varid, 32, SZIP_PIXELS_PER_BLOCK);
- #else
- char errmsg[MAX_ERR_LENGTH];
- snprintf(errmsg, MAX_ERR_LENGTH,
+ SET(SOURCES_MAIN Apps_krino.cpp)
+
+diff --color -urt Trilinos-trilinos-release-14-0-0.orig/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp Trilinos-trilinos-release-14-0-0.new/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp
+--- Trilinos-trilinos-release-14-0-0.orig/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp 2023-05-18 08:34:11.735903734 +0200
++++ Trilinos-trilinos-release-14-0-0.new/packages/teuchos/core/src/Teuchos_BigUIntDecl.hpp 2023-05-18 08:29:49.596832958 +0200
+@@ -43,7 +43,7 @@
+ #define TEUCHOS_BIG_UINT_DECL_HPP
+
+ #include <iosfwd>
+-
++#include <cstdint>
+ /*! \file Teuchos_BigUIntDecl.hpp
+ \brief Arbitrary-precision unsigned integer declaration.
+ */