summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2021-01-30 15:42:31 +0100
committerJan Cholasta2021-01-30 15:42:31 +0100
commit4499cf7e9ea39618ddce2e6c9f8687092035df74 (patch)
treee2cb44c1be7caa209c2ac88233b2acbf16d4d39d
parente50531fde15aa32f0ffd2c3b4f46777d3c09d2fc (diff)
downloadaur-4499cf7e9ea39618ddce2e6c9f8687092035df74.tar.gz
raze-git-0.8.0_beta+142+ga0be30fac-1
-rw-r--r--0001-Fix-file-paths.patch23
-rw-r--r--PKGBUILD6
2 files changed, 16 insertions, 13 deletions
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index 0ce76b272a0a..d862910407a1 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,16 +1,16 @@
-From 8cde74c80be9fdfb0e00bb00b85b5bfed0e70da7 Mon Sep 17 00:00:00 2001
+From 59d406377474990b43356132a7157eb23ccdcef4 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Thu, 6 Feb 2020 07:59:18 +0100
Subject: [PATCH] Fix file paths
---
source/common/platform/posix/sdl/i_main.cpp | 14 +-------------
- source/core/gameconfigfile.cpp | 13 +------------
+ source/core/gameconfigfile.cpp | 15 ++-------------
source/core/gamecontrol.cpp | 2 +-
- 3 files changed, 3 insertions(+), 26 deletions(-)
+ 3 files changed, 4 insertions(+), 27 deletions(-)
diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
-index 7fc179a51..fb4ce733e 100644
+index a984721fc..ddc209e34 100644
--- a/source/common/platform/posix/sdl/i_main.cpp
+++ b/source/common/platform/posix/sdl/i_main.cpp
@@ -129,19 +129,7 @@ int main (int argc, char **argv)
@@ -35,7 +35,7 @@ index 7fc179a51..fb4ce733e 100644
I_StartupJoysticks();
diff --git a/source/core/gameconfigfile.cpp b/source/core/gameconfigfile.cpp
-index b532b2925..8ffd663b1 100644
+index 115c737be..c83ce70ed 100644
--- a/source/core/gameconfigfile.cpp
+++ b/source/core/gameconfigfile.cpp
@@ -100,15 +100,10 @@ FGameConfigFile::FGameConfigFile ()
@@ -54,9 +54,12 @@ index b532b2925..8ffd663b1 100644
#endif
SetValueForKey ("Path", "$STEAM", true); // also covers GOG.
-@@ -130,11 +125,8 @@ FGameConfigFile::FGameConfigFile ()
+@@ -128,13 +123,10 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey ("Path", "$GAMEDIR", true);
+ #else
SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
- SetValueForKey ("Path", SHARE_DIR, true);
+- SetValueForKey ("Path", SHARE_DIR, true);
++ SetValueForKey ("Path", "/usr/share/raze", true);
SetValueForKey ("Path", "/usr/share/games/jfduke3d", true);
- SetValueForKey ("Path", "/usr/local/share/games/jfduke3d", true);
SetValueForKey ("Path", "/usr/share/games/eduke32", true);
@@ -79,10 +82,10 @@ index b532b2925..8ffd663b1 100644
}
diff --git a/source/core/gamecontrol.cpp b/source/core/gamecontrol.cpp
-index cf89415e5..512577cf6 100644
+index c034ff152..1ba99a14b 100644
--- a/source/core/gamecontrol.cpp
+++ b/source/core/gamecontrol.cpp
-@@ -826,7 +826,7 @@ int RunGame()
+@@ -823,7 +823,7 @@ int RunGame()
FString logfile = Args->TakeValue("+logfile");
// As long as this engine is still in prerelease mode let's always write a log file.
@@ -92,5 +95,5 @@ index cf89415e5..512577cf6 100644
if (logfile.IsNotEmpty())
{
--
-2.28.0
+2.30.0
diff --git a/PKGBUILD b/PKGBUILD
index 8e1e4b64ddf3..547eee8198be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=raze-git
-pkgver=0.7.3_alpha+17+gc93b8f3e5
+pkgver=0.8.0_beta+142+ga0be30fac
pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech (git version)'
arch=('x86_64')
@@ -27,7 +27,7 @@ source=("Raze::git+https://github.com/coelckers/Raze"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- 'dd4cb8fc741febe22375d87cc072a58afa3913022ecaea33e9f426cb1fa820c2'
+ '5655c8685ebebf8ac7491dda3b4c8efd3b06f979111315df3fd87674dacfa963'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
pkgver() {
@@ -45,7 +45,7 @@ build() {
mkdir -p build
cmake -B build \
-D CMAKE_BUILD_TYPE=Release \
- -D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/raze\\\"" \
+ -D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=." \
-D DYN_GTK=OFF \
-D DYN_OPENAL=OFF
make -C build