summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBouke Sybren Haarsma2024-02-02 19:26:46 +0100
committerBouke Sybren Haarsma2024-02-02 19:31:54 +0100
commit44a63d3412caa7c51cac9326754635ab9276ef5d (patch)
tree0ed332e5ab15624d0db0406649a72e3314d861f6
parent150174387017479cdf1b2a8ce8c12ce1d40bceae (diff)
downloadaur-44a63d3412caa7c51cac9326754635ab9276ef5d.tar.gz
Various nits and fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD36
2 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e807179c0296..98b9764a434b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -38,6 +38,8 @@ pkgbase = gamescope-git
provides = gamescope
conflicts = gamescope
source = git+https://github.com/ValveSoftware/gamescope.git
+ source = git+https://github.com/nothings/stb.git#commit=af1a5bc352164740c1cc1354942b1c6b72eacb8a
+ b2sums = SKIP
b2sums = SKIP
pkgname = gamescope-git
diff --git a/PKGBUILD b/PKGBUILD
index d788c07a8780..a4d6c32e6092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
# PKGBUILD based on the official Arch gamescope PKGBUILD
# Maintainer - Sid Pranjale <sidpranjale127@protonmail.com>
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Maintainer: Bouke Sybren Haarsma <boukehaarsma23 at gmail dot com>
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Maintainer: Giancarlo Razzolini <grazzolini@archlinux.org>
# Contributor: Samuel "scrufulufugus" Monson <smonson@irbash.net>
@@ -49,16 +51,32 @@ makedepends=(
wayland-protocols
)
source=(
- git+https://github.com/ValveSoftware/gamescope.git
+ "git+https://github.com/ValveSoftware/gamescope.git"
+ "git+https://github.com/nothings/stb.git#commit=af1a5bc352164740c1cc1354942b1c6b72eacb8a"
)
-b2sums=('SKIP')
+b2sums=('SKIP'
+ 'SKIP')
+
provides=("$_pkgname")
conflicts=("$_pkgname")
prepare() {
cd $_pkgname
+ # This really should be a pacman feature...
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ git apply "../$src"
+ done
+
git submodule update --init --recursive --depth=1
git -c protocol.file.allow=always submodule update
+ # make stb.wrap use our local clone
+ rm -rf subprojects/stb
+ git clone "$srcdir/stb" subprojects/stb
+ cp -av subprojects/packagefiles/stb/* subprojects/stb/ # patch from the .wrap we elided
}
pkgver() {
@@ -67,17 +85,17 @@ pkgver() {
}
build() {
- cd $_pkgname
- meson build \
- -Dforce_fallback_for=stb \
+ export LDFLAGS="$LDFLAGS -lrt"
+ arch-meson "${_pkgname}" build \
-Dpipewire=enabled
- ninja -C build
+ meson compile -C build
}
package() {
- DESTDIR="${pkgdir}" meson install -C $_pkgname/build \
- --skip-subprojects
- install -Dm 644 $_pkgname/LICENSE -t "${pkgdir}"/usr/share/licenses/gamescope/
+ meson install -C build --skip-subprojects --destdir="${pkgdir}"
+
+ cd "$srcdir/$_pkgname"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/"
}
# vim: ts=2 sw=2 et: