summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmf2015-09-06 01:25:33 +0200
committerjmf2015-09-06 01:25:33 +0200
commit44a9f4c98a5a2ff522a307e73447544707559319 (patch)
tree47817830b120e214b38fda869dd20633a202f961
parent960dc4dc885549322aff8505504d13216608c6ec (diff)
downloadaur-44a9f4c98a5a2ff522a307e73447544707559319.tar.gz
Fixing compiling, changing the PKGBUILD to move the right files to the pkgdir
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a49dd5e40a96..ef35da0a9fa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,7 @@ pkgbase = openscenegraph-git
depends = xine-lib
depends = curl
provides = openscenegraph-git
+ provides = openscenegraph
conflicts = openscenegraph
conflicts = openscenegraph-svn
source = git://github.com/openscenegraph/osg.git
diff --git a/PKGBUILD b/PKGBUILD
index 3eb0ae78e968..7443e5d3f279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,24 @@ pkgdesc="An open source, high performance real-time graphics toolkit - git mirro
arch=('i686' 'x86_64')
url="http://www.openscenegraph.org/"
license=('GPL')
-groups=()
depends=('giflib' 'jasper' 'librsvg' 'xine-lib' 'curl')
makedepends=()
-provides=('openscenegraph-git')
+provides=('openscenegraph-git' 'openscenegraph')
conflicts=('openscenegraph' 'openscenegraph-svn')
source=(git://github.com/openscenegraph/osg.git)
md5sums=('SKIP')
build() {
- mkdir ${srcdir}/${_gitname}-build/
+ mkdir ${srcdir}/${_gitname}-build/
cd "${srcdir}/${_gitname}-build/"
cmake ../${_gitname} -DCMAKE_INSTALL_PREFIX=/usr -DLIBRARY_OUTPUT_PATH=/usr/lib -DCMAKE_BUILD_TYPE=Release
make || return 1
}
package(){
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${_gitname}-build"
make DESTDIR="${pkgdir}/" install
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "${srcdir}/${_gitname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"
}