summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Vincent2017-03-19 11:27:44 +0100
committerMaxime Vincent2017-03-19 11:27:44 +0100
commit44b825170f3d210f3451a32a668378195d802118 (patch)
treee8d106523257d8de2b681dc7125b21fbc76b46c9
downloadaur-44b825170f3d210f3451a32a668378195d802118.tar.gz
wolfSSL git version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0d95b1185bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wolfssl-git
+ pkgdesc = A small, fast, portable implementation of TLS/SSL for embedded devices to the cloud. (formerly CyaSSL)
+ pkgver = 20160319.52215b3
+ pkgrel = 1
+ url = https://www.wolfssl.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = bash
+ provides = wolfssl
+ conflicts = wolfssl
+ source = git+https://github.com/wolfSSL/wolfssl.git
+ sha256sums = SKIP
+
+pkgname = wolfssl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caf1ea9c4d03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Maxime Vincent <maxime.vince@gmail.com>
+
+_pkgname=wolfssl
+pkgname=${_pkgname}-git
+pkgver=20160319.52215b3
+pkgrel=1
+pkgdesc='A small, fast, portable implementation of TLS/SSL for embedded devices to the cloud. (formerly CyaSSL) '
+arch=(i686 x86_64)
+license=(GPL)
+depends=('bash')
+makedepends=('git')
+url='https://www.wolfssl.com/'
+source=(git+https://github.com/wolfSSL/wolfssl.git)
+sha256sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+build() {
+ cd $_pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --disable-fastmath \
+ --disable-fasthugemath --disable-bump \
+ --enable-opensslextra --enable-fortress \
+ --enable-keygen --enable-certgen \
+ --disable-debug --disable-ntru --disable-examples
+ make
+}
+
+package() {
+ cd $_pkgname
+ make install DESTDIR="$pkgdir"
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$_pkgname/COPYING
+ libtool --finish /usr/lib
+}