summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze2017-02-23 12:09:49 +0100
committerNoel Kuntze2017-02-23 12:09:49 +0100
commit44edaf247938c8c222f54b6ba9e9718059d12a17 (patch)
treeb771eff86d59ea6feea7db5ffaa12ac5693e7008
parent8389bfb40c4bf7d52d550f1be58c48a5a5168455 (diff)
downloadaur-44edaf247938c8c222f54b6ba9e9718059d12a17.tar.gz
Bump to 20170222, secondary changes
Bump to 20170222, enable verification of the signature, use release archive, correctly quote strings with variables, use ${var}
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e3a635c3af4..f14bd6471eef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jan 24 22:13:50 UTC 2016
+# Thu Feb 23 11:07:30 UTC 2017
pkgbase = libqcow
pkgdesc = Library and tools to support QEMU copy-on-write image format (QCOW, QCOW2), including a FUSE-based mount utility
- pkgver = 20160123
+ pkgver = 20170222
pkgrel = 1
url = https://github.com/libyal/libqcow/
arch = i686
@@ -13,8 +13,10 @@ pkgbase = libqcow
makedepends = python
depends = fuse
depends = openssl
- source = https://github.com/libyal/libqcow/archive/20160123.tar.gz
- sha256sums = 1294e2e08979f388360a85ef56db5b580da75f882148f868ac7a6f87b31907ba
+ source = https://github.com/libyal/libqcow/releases/download/20170222/libqcow-alpha-20170222.tar.gz
+ source = https://github.com/libyal/libqcow/releases/download/20170222/libqcow-alpha-20170222.tar.gz.asc
+ sha256sums = 8b4a3f97b3091cb8dc4990a03a1c9c42385e37d876eba6e6513b1e9104e9512d
+ sha256sums = SKIP
pkgname = libqcow
diff --git a/PKGBUILD b/PKGBUILD
index f8f7d98665d7..61adb76ea435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: David McIlwraith <archaios at archaios dot net>
pkgname=libqcow
-pkgver=20160123
+pkgver=20170222
pkgrel=1
pkgdesc="Library and tools to support QEMU copy-on-write image format (QCOW, QCOW2), including a FUSE-based mount utility"
url="https://github.com/libyal/libqcow/"
@@ -8,18 +8,20 @@ arch=('i686' 'x86_64')
license=('LGPL3')
depends=('fuse' 'openssl')
makedepends=('zlib' 'openssl' 'python')
-source=("https://github.com/libyal/libqcow/archive/$pkgver.tar.gz")
-sha256sums=('1294e2e08979f388360a85ef56db5b580da75f882148f868ac7a6f87b31907ba')
+source=("https://github.com/libyal/libqcow/releases/download/${pkgver}/${pkgname}-alpha-${pkgver}.tar.gz"
+ "https://github.com/libyal/libqcow/releases/download/${pkgver}/${pkgname}-alpha-${pkgver}.tar.gz.asc")
+
+validpgpkeys=('0ED9020DA90D3F6E70BD3945D9625E5D7AD0177E')
+sha256sums=('8b4a3f97b3091cb8dc4990a03a1c9c42385e37d876eba6e6513b1e9104e9512d'
+ 'SKIP')
build(){
- cd $srcdir/$pkgname-$pkgver
- ./synclibs.sh
- ./autogen.sh
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --enable-python --enable-verbose-output --enable-debug-output --enable-wide-character-type
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}