summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-03-04 19:06:35 +0100
committerhaawda2019-03-04 19:06:35 +0100
commit44fffe2d093fc1bede8da6a2a05d67c56fb4b357 (patch)
treea62f7ca117c778248ff3c3245c7c8cb46ac67e22
downloadaur-44fffe2d093fc1bede8da6a2a05d67c56fb4b357.tar.gz
initial upload
-rw-r--r--.SRCINFO22
-rw-r--r--Makefile.patch27
-rw-r--r--PKGBUILD34
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..376acc72ebd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = emacs-nim-mode-git
+ pkgdesc = Emacs mode for the nim programming language
+ pkgver = 0.4.1r68.ga508b4b
+ pkgrel = 1
+ url = https://github.com/nim-lang/nim-mode
+ arch = any
+ license = GPL3
+ depends = emacs-dash
+ depends = emacs-epc
+ depends = emacs-ctable
+ depends = emacs-epl
+ depends = emacs-deferred
+ depends = emacs-company-mode
+ depends = emacs-commander
+ depends = emacs-flycheck
+ source = git+https://github.com/nim-lang/nim-mode.git
+ source = Makefile.patch
+ sha256sums = SKIP
+ sha256sums = 20fef5db29d67788dd22cbc9dd97dd2a778a66a0b6f0b80aa9776d08cadb4576
+
+pkgname = emacs-nim-mode-git
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..61f8269ab0fa
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,27 @@
+diff -Naur nim-mode-0.4.1.orig/Makefile nim-mode-0.4.1.new/Makefile
+--- nim-mode-0.4.1.orig/Makefile 2018-10-03 23:47:34.466464558 +0200
++++ nim-mode-0.4.1.new/Makefile 2018-10-04 11:41:31.126154170 +0200
+@@ -3,20 +3,19 @@
+
+ cask_dir_exists := $(shell find ./ -type d -name ".cask")
+
+-all: test
++all: compile unit
+
+ test: clean-elc
+ $(if $(cask_dir_exists), $(skip), ${MAKE} install-dependencies)
+ ${MAKE} unit
+ ${MAKE} compile
+ ${MAKE} unit
+- ${MAKE} clean-elc
+
+ compile:
+- ${CASK} exec ${EMACS} -Q -batch -L . -f batch-byte-compile *.el
++ ${EMACS} -Q -batch -L /usr/share/emacs/site-lisp/flycheck -L /usr/share/emacs/site-lisp/ -L /usr/share/emacs/site-lisp/epc -L . -f batch-byte-compile *.el
+
+ unit:
+- ${CASK} exec buttercup -L .
++
+
+ install-dependencies:
+ ${CASK} install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acd69ffc646d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-nim-mode-git
+pkgver=0.4.1r68.ga508b4b
+pkgrel=1
+pkgdesc="Emacs mode for the nim programming language"
+arch=('any')
+url="https://github.com/nim-lang/nim-mode"
+license=('GPL3')
+depends=('emacs-dash' 'emacs-epc' 'emacs-ctable' 'emacs-epl' 'emacs-deferred' 'emacs-company-mode' 'emacs-commander' 'emacs-flycheck')
+source=("git+https://github.com/nim-lang/nim-mode.git" Makefile.patch)
+sha256sums=('SKIP' '20fef5db29d67788dd22cbc9dd97dd2a778a66a0b6f0b80aa9776d08cadb4576')
+
+pkgver() {
+ cd nim-mode
+ git describe --tags --long | sed 's+-+r+' | tr - .|cut -c2-
+}
+
+prepare() {
+ cd nim-mode
+ patch -Np1 < "$srcdir"/Makefile.patch
+}
+
+build() {
+ cd nim-mode
+ make
+}
+
+package() {
+ cd nim-mode
+ install -dm755 "$pkgdir"/usr/share/emacs/site-lisp/
+ cp *.el{,c} "$pkgdir"/usr/share/emacs/site-lisp/
+}