summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-01-26 11:46:09 -0500
committerCarlos Aznarán2024-01-26 11:46:09 -0500
commit4504e6f19a995f52bfbc5eb1ffd86e84b1b79ef1 (patch)
treef935a4537cd56bc8e0d12e9d6a7e5d2d5bcc32a6
parent37b3eb5e079714d2b3c74dc19547b342f6441d60 (diff)
downloadaur-4504e6f19a995f52bfbc5eb1ffd86e84b1b79ef1.tar.gz
Bump version to 0.0.36
-rw-r--r--.SRCINFO57
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD81
3 files changed, 101 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 873a251fb42b..482c561efd41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,53 @@
pkgbase = openems
- pkgdesc = a free and open source EC-FDTD solver
- pkgver = 0.0.35
+ pkgdesc = free and open electromagnetic field solver using the FDTD method
+ pkgver = 0.0.36
pkgrel = 1
- url = http://openems.de
+ url = https://openEMS.de
arch = i686
arch = x86_64
license = GPL3
- depends = qt5-base
- depends = tinyxml
- depends = hdf5
+ makedepends = git
+ makedepends = cmake
+ makedepends = nlohmann-json
+ makedepends = python-h5py-openmpi
+ depends = hdf5-openmpi
depends = boost
- depends = vtk
- depends = unixodbc
depends = cgal
- depends = cmake
- depends = openmpi
- source = http://openems.de/download/src/openEMS-v0.0.35.tar.bz2
- sha256sums = e5b514281466872c52f8f8509a712fd422d89269df7c02e4a6606f8f20757478
+ depends = tinyxml
+ depends = qt5-base
+ depends = unixodbc
+ depends = vtk
+ depends = fmt
+ depends = verdict
+ depends = libxcursor
+ depends = glew
+ depends = jsoncpp
+ depends = ospray
+ depends = openxr
+ depends = openvr
+ depends = ffmpeg
+ depends = postgresql-libs
+ depends = netcdf
+ depends = pdal
+ depends = mariadb-libs
+ depends = liblas
+ depends = cgns
+ depends = adios2
+ depends = libharu
+ depends = gl2ps
+ source = openEMS-0.0.36::git+https://github.com/thliebig/openEMS-Project.git#tag=v0.0.36
+ source = github.com-thliebig-csxcad::git+https://github.com/thliebig/CSXCAD.git
+ source = github.com-thliebig-qcsxcad::git+https://github.com/thliebig/QCSXCAD.git
+ source = github.com-thliebig-appcsxcad::git+https://github.com/thliebig/AppCSXCAD.git
+ source = github.com-thliebig-openems::git+https://github.com/thliebig/openEMS.git
+ source = github.com-thliebig-fparser::git+https://github.com/thliebig/fparser.git
+ source = github.com-thliebig-ctb::git+https://github.com/thliebig/CTB.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = openems
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index ec31f3211123..fda9d5adf7b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,65 @@
-# Maintainer: Thomas Pointhuber <thomas.pointhuber@gmx.at>
-# Co-maintainer: Thorsten Liebig
-pkgname=openems
-pkgver=0.0.35
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Thomas Pointhuber <thomas.pointhuber@gmx.at>
+# Contributor: Thorsten Liebig
+_base=openEMS
+pkgname=${_base,,}
+pkgver=0.0.36
pkgrel=1
-pkgdesc="a free and open source EC-FDTD solver"
-arch=('i686' 'x86_64')
-url='http://openems.de'
-license=('GPL3')
-groups=()
-depends=('cmake' 'qt5-base' 'tinyxml' 'hdf5' 'boost' 'vtk' 'unixodbc' 'cgal' 'openmpi')
-makedepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("http://openems.de/download/src/openEMS-v$pkgver.tar.bz2")
-noextract=()
-sha256sums=('e5b514281466872c52f8f8509a712fd422d89269df7c02e4a6606f8f20757478')
+pkgdesc="free and open electromagnetic field solver using the FDTD method"
+arch=(i686 x86_64)
+url="https://${_base}.de"
+license=(GPL3)
+depends=(hdf5-openmpi boost cgal tinyxml qt5-base unixodbc
+ vtk fmt verdict libxcursor glew jsoncpp ospray openxr openvr ffmpeg
+ postgresql-libs netcdf pdal mariadb-libs liblas cgns adios2 libharu gl2ps)
+makedepends=(git cmake nlohmann-json python-h5py-openmpi)
+optdepends=() # octave paraview hyp2mat
+source=(${_base}-${pkgver}::git+https://github.com/thliebig/${_base}-Project.git#tag=v${pkgver}
+ github.com-thliebig-csxcad::git+https://github.com/thliebig/CSXCAD.git
+ github.com-thliebig-qcsxcad::git+https://github.com/thliebig/QCSXCAD.git
+ github.com-thliebig-appcsxcad::git+https://github.com/thliebig/AppCSXCAD.git
+ github.com-thliebig-openems::git+https://github.com/thliebig/openEMS.git
+ github.com-thliebig-fparser::git+https://github.com/thliebig/fparser.git
+ github.com-thliebig-ctb::git+https://github.com/thliebig/CTB.git)
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd ${_base}-${pkgver}
+ sed -i 's/..\/CSXCAD.git/https:\/\/github.com\/thliebig\/CSXCAD.git/' .gitmodules
+ sed -i 's/..\/QCSXCAD.git/https:\/\/github.com\/thliebig\/QCSXCAD.git/' .gitmodules
+ sed -i 's/..\/AppCSXCAD.git/https:\/\/github.com\/thliebig\/AppCSXCAD.git/' .gitmodules
+ sed -i 's/..\/openEMS.git/https:\/\/github.com\/thliebig\/openEMS.git/' .gitmodules
+ sed -i 's/..\/fparser.git/https:\/\/github.com\/thliebig\/fparser.git/' .gitmodules
+ sed -i 's/..\/CTB.git/https:\/\/github.com\/thliebig\/CTB.git/' .gitmodules
+ git submodule init
+
+ git config submodule.CSXCAD.url "${srcdir}/github.com-thliebig-csxcad"
+ git config submodule.QCSXCAD.url "${srcdir}/github.com-thliebig-qcsxcad"
+ git config submodule.AppCSXCAD.url "${srcdir}/github.com-thliebig-appcsxcad"
+ git config submodule.openEMS "${srcdir}/github.com-thliebig-openems"
+ git config submodule.fparser "${srcdir}/github.com-thliebig-fparser"
+ git config submodule.CTB "${srcdir}/github.com-thliebig-ctb"
+
+ git -c protocol.file.allow=always submodule update
+}
build() {
- cd "openEMS"
- ./update_openEMS.sh $(pwd)/bin/
+ cd ${_base}-${pkgver}
+ ./update_openEMS.sh ${PWD}/bin \
+ --with-hyp2mat \
+ --with-CTB \
+ --with-MPI \
+ --python
}
package() {
- cd "openEMS/bin"
+ cd ${_base}-${pkgver}/bin
install -d "$pkgdir/usr"
cp -r * "$pkgdir/usr/"