summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:46:15 +0000
committerXyne2015-06-21 02:46:15 +0000
commit451ce9c1281d23f6d1d4597780c4fb8aed93e04a (patch)
treee756d32ce168a85b4e6b321bad02e76f32b5fdea
downloadaur-451ce9c1281d23f6d1d4597780c4fb8aed93e04a.tar.gz
Initial import.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--texlive-mhchem-bundle.install14
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1152e451ebd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = texlive-mhchem-bundle
+ pkgdesc = Typeset chemical formulae/equations and Risk and Safety phrases in LaTeX.
+ pkgver = 4.01
+ pkgrel = 1
+ url = http://www.ctan.org/tex-archive/macros/latex/contrib/mhchem/
+ install = texlive-mhchem-bundle.install
+ arch = any
+ license = LPPL
+ depends = texlive-bin
+ provides = texlive-mhchem
+ provides = texlive-rsphrase
+ conflicts = texlive-mhchem
+ conflicts = texlive-rsphrase
+ source = http://mirror.ctan.org/macros/latex/contrib/mhchem.zip
+ sha256sums = 0d9b99f7c110e1ce71619dff90d64308917afbe2afa6adabe7006d309accb6c2
+
+pkgname = texlive-mhchem-bundle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0d0b8dfc363
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Xyne <ac xunilhcra enyx, backwards>
+
+_basename=mhchem
+pkgname=texlive-mhchem-bundle
+pkgver=4.01
+pkgrel=1
+pkgdesc="Typeset chemical formulae/equations and Risk and Safety phrases in LaTeX."
+arch=('any')
+depends=('texlive-bin')
+url="http://www.ctan.org/tex-archive/macros/latex/contrib/$_basename/"
+provides=(texlive-"$_basename" texlive-rsphrase)
+conflicts=(texlive-"$_basename" texlive-rsphrase)
+license=('LPPL')
+source=(http://mirror.ctan.org/macros/latex/contrib/"$_basename".zip)
+install=$pkgname.install
+
+package() {
+ cd -- "$srcdir/$_basename"
+ for sty in *.sty
+ do
+ install -Dm644 "$sty" "$pkgdir/usr/share/texmf/tex/latex/$_basename/$sty"
+ done
+
+ for doc in "$_basename".{pdf,tex}
+ do
+ install -Dm644 "$doc" "$pkgdir/usr/share/texmf/tex/latex/$_basename/doc/$doc"
+ done
+}
+
+sha256sums=('0d9b99f7c110e1ce71619dff90d64308917afbe2afa6adabe7006d309accb6c2')
diff --git a/texlive-mhchem-bundle.install b/texlive-mhchem-bundle.install
new file mode 100644
index 000000000000..9ad68f217d03
--- /dev/null
+++ b/texlive-mhchem-bundle.install
@@ -0,0 +1,14 @@
+# from the texlive-bin package
+post_install() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+# echo -n "creating all formats..."
+# usr/bin/fmtutil-sys --all 1>/dev/null
+# echo " done."
+# echo " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+