summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-10 14:51:33 -0300
committerDaniel Bermond2022-11-10 14:51:33 -0300
commit4538735d9ecd2c1736bea840d21b799e3b5cdb29 (patch)
treedf72c0a5f87874a258374ed3ed2ccd252b9f5dbc
parent142e25ddf5f1780c8cbcba6037e114c50e5d573c (diff)
downloadaur-4538735d9ecd2c1736bea840d21b799e3b5cdb29.tar.gz
Update to version 4.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--010-astc-encoder-use-shared-library.patch4
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be59e71e7913..49c9973245a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 4.0.0
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.0.0
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.2.0
source = git+https://github.com/google/googletest.git
source = 010-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210
+ sha256sums = de18c29f9a12f00562487e73d255135184bb74cd0ebacd0576363655e7071e55
pkgname = astc-encoder
diff --git a/010-astc-encoder-use-shared-library.patch b/010-astc-encoder-use-shared-library.patch
index a1efe29e5c15..89b87911ba69 100644
--- a/010-astc-encoder-use-shared-library.patch
+++ b/010-astc-encoder-use-shared-library.patch
@@ -43,7 +43,7 @@
endif()
macro(astcenc_set_properties NAME)
-@@ -310,16 +314,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+@@ -302,16 +306,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
endif()
@@ -64,7 +64,7 @@
PRIVATE
$<$<CXX_COMPILER_ID:MSVC>:/W3>)
-@@ -330,9 +334,10 @@ if(${CLI})
+@@ -322,9 +326,10 @@ if(${CLI})
astcenccli_version.h
ESCAPE_QUOTES @ONLY)
diff --git a/PKGBUILD b/PKGBUILD
index eca3abf01d96..96174a2c58f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=4.0.0
+pkgver=4.2.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -14,12 +14,12 @@ source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
'010-astc-encoder-use-shared-library.patch')
sha256sums=('SKIP'
'SKIP'
- 'dbd5d3db47c01435698e6332a9049e6b977a952ee6628aa55bc0866d7da36210')
+ 'de18c29f9a12f00562487e73d255135184bb74cd0ebacd0576363655e7071e55')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
- git -C astc-encoder submodule update
+ git -C astc-encoder -c protocol.file.allow='always' submodule update
patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-use-shared-library.patch"
}