summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Morr2016-08-15 16:06:16 +0200
committerSebastian Morr2016-08-15 16:06:16 +0200
commit456fa787c5221cededb3215b27f37adea99662ea (patch)
tree0475a64476aff239194664b9988355514016a78c
downloadaur-456fa787c5221cededb3215b27f37adea99662ea.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--change-default-wav-path.patch12
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..056b651c796b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bucklespring-git
+ pkgdesc = Nostalgia bucklespring keyboard sound, sampled from IBM's Model-M
+ pkgver = 20160815
+ pkgrel = 1
+ url = http://github.com/zevv/bucklespring
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = openal
+ depends = alure
+ depends = libxtst
+ source = git+https://github.com/zevv/bucklespring
+ source = change-default-wav-path.patch
+ sha1sums = SKIP
+ sha1sums = 3658e6878ce662cafbb56aa1497aa102da37d27e
+
+pkgname = bucklespring-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27e2e677792b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Sebastian Morr <sebastian@morr.cc>
+
+pkgname=bucklespring-git
+_gitname=bucklespring
+pkgver=20160815
+pkgrel=1
+pkgdesc="Nostalgia bucklespring keyboard sound, sampled from IBM's Model-M"
+arch=('i686' 'x86_64')
+url="http://github.com/zevv/bucklespring"
+license=('MIT')
+depends=('openal' 'alure' 'libxtst')
+makedepends=('git')
+source=('git+https://github.com/zevv/bucklespring' change-default-wav-path.patch)
+sha1sums=('SKIP' '3658e6878ce662cafbb56aa1497aa102da37d27e')
+
+prepare() {
+ cd "$srcdir/$_gitname"
+ patch -p1 <../change-default-wav-path.patch
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir"/usr/bin
+ cp buckle "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/bucklespring
+ cp wav/* "$pkgdir"/usr/share/bucklespring
+}
diff --git a/change-default-wav-path.patch b/change-default-wav-path.patch
new file mode 100644
index 000000000000..fe01d1ea2432
--- /dev/null
+++ b/change-default-wav-path.patch
@@ -0,0 +1,12 @@
+diff -aur bucklespring.pristine/main.c bucklespring.new/main.c
+--- bucklespring.pristine/main.c 2016-08-15 15:59:04.955720103 +0200
++++ bucklespring.new/main.c 2016-08-15 15:59:53.392386416 +0200
+@@ -51,7 +51,7 @@
+ static int opt_stereo_width = 50;
+ static int opt_gain = 100;
+ static const char *opt_device = NULL;
+-static const char *opt_path_audio = "./wav";
++static const char *opt_path_audio = "/usr/share/bucklespring";
+
+
+ int main(int argc, char **argv)