summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2017-09-18 14:51:16 +0200
committerCarsten Feuls2017-09-18 14:51:16 +0200
commit4574f4ec7c6264b7d29b33ae7e926ead66375767 (patch)
tree939eaa85702c7931cb3eda478797f74f43280af5
parent8886e9f4921af288980f38ed602ae9fee95d4a49 (diff)
downloadaur-4574f4ec7c6264b7d29b33ae7e926ead66375767.tar.gz
New to aur
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dcc6040c16a..b4fa3456b98f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Mon Sep 18 12:50:24 UTC 2017
pkgbase = haskell-curl
pkgdesc = Haskell binding to libcurl
pkgver = 1.3.8
pkgrel = 1
- url = None
+ url = http://hackage.haskell.org/package/curl
arch = any
license = BSD3
depends = ghc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 3b2351b52f17..ece9a2ad7dca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
-# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de>
# Generated by hkg2arch --> https://github.com/christopherloen/hkg2arch
+
hkgname=curl
pkgname=haskell-curl
pkgrel=1
pkgver=1.3.8
pkgdesc='Haskell binding to libcurl'
arch=(any)
-url='None'
+url='http://hackage.haskell.org/package/curl'
license=(BSD3)
-depends=(ghc haskell-base haskell-bytestring haskell-containers)
+depends=('ghc' 'haskell-base' 'haskell-bytestring' 'haskell-containers')
options=(strip)
-source=(https://hackage.haskell.org/package/curl-1.3.8/curl-1.3.8.tar.gz)
-sha256sums=(9087c936bfcdb865bad3166baa3f12bf37acf076fa76010e3b5f82a1d485446e)
+source=(https://hackage.haskell.org/package/${hkgname}-${pkgver}/${hkgname}-${pkgver}.tar.gz)
+
+prepare() {
+ cd ${srcdir}/${hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir='$compiler'/site-local/'$pkgid'
+}
+
build(){
- cd ${srcdir}/${hkgname}-${pkgver}
- runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir='$compiler'/site-local/'$pkgid'
+ cd ${srcdir}/${hkgname}-${pkgver}
runhaskell Setup build
runhaskell Setup haddock
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
- }
+}
+
package() {
cd ${srcdir}/${hkgname}-${pkgver}
install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
@@ -31,3 +37,4 @@ package() {
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
}
+sha256sums=('9087c936bfcdb865bad3166baa3f12bf37acf076fa76010e3b5f82a1d485446e')