summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2016-12-30 19:02:54 -0200
committerRafael Fontenelle2016-12-30 19:03:23 -0200
commit458da6a6051c051e3f9d14f635ea3baa34ed6bb5 (patch)
treed6c712750c5ecd89f55c7bfc6803b02e7056159f
downloadaur-458da6a6051c051e3f9d14f635ea3baa34ed6bb5.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD49
-rw-r--r--chronojump-git.install8
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff810da4e7ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri Dec 30 21:03:10 UTC 2016
+pkgbase = chronojump-git
+ pkgdesc = Measurement, management and statistics of sport short-time tests
+ pkgver = 1.6.2.451.g00e63dd5
+ pkgrel = 1
+ url = http://chronojump.org/
+ install = chronojump-git.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = gtk-sharp-2
+ makedepends = mono
+ makedepends = intltool
+ makedepends = git
+ depends = gstreamer0.10-base
+ depends = python
+ depends = gtk2
+ provides = chronojump
+ conflicts = chronojump
+ options = !libtool
+ source = git+https://git.gnome.org/browse/chronojump
+ md5sums = SKIP
+
+pkgname = chronojump-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7109aa6dbba4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+
+_name=chronojump
+pkgname=$_name-git
+pkgver=1.6.2.451.g00e63dd5
+pkgrel=1
+pkgdesc="Measurement, management and statistics of sport short-time tests"
+arch=('x86_64' 'i686')
+url="http://chronojump.org/"
+license=('GPL')
+depends=('gstreamer0.10-base' 'python' 'gtk2')
+makedepends=('gtk-sharp-2' 'mono' 'intltool' 'git')
+checkdepends=()
+optdepends=()
+provides=($_name)
+conflicts=($_name)
+options=(!libtool)
+install=$pkgname.install
+source=("git+https://git.gnome.org/browse/$_name")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ git describe --long | sed 's/-/./g'
+}
+
+prepare() {
+ cd "$_name"
+ NOCONFIGURE=1 ./autogen.sh
+ # fix path for mono 4.6.1.3-1
+ sed -i 's|/mono/4.0/|/mono/4.5/|' configure
+
+}
+
+build() {
+ cd "$_name"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$_name"
+ make -k check || true
+}
+
+package() {
+ cd "$_name"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/chronojump-git.install b/chronojump-git.install
new file mode 100644
index 000000000000..750416f0ce2e
--- /dev/null
+++ b/chronojump-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "NOTE: To run Chronojump with Chronopic as normal user make sure to add yourself into 'dialout' group"
+}
+
+post_upgrade() {
+ post_install
+}
+