summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-08-08 01:30:42 +0200
committerFilippo Berto2020-08-08 01:30:42 +0200
commit45bc6ba927efb6c0020509c4630eceb6615ce94e (patch)
tree5fa9dacf4a76a4bfc4bd16f08cd1215a53b6ce25
downloadaur-45bc6ba927efb6c0020509c4630eceb6615ce94e.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD36
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c3b8a148526
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = mini-ndn
+ pkgdesc = Lightweight networking emulation tool that enables testing, experimentation, and research on the NDN platform based on Mininet
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/named-data/mini-ndn
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = ndn-cxx
+ makedepends = ndn-nfd
+ makedepends = ndn-chronosync
+ makedepends = ndn-tools
+ makedepends = ndn-nlsr
+ makedepends = ndn-infoedit
+ makedepends = mininet-git
+ makedepends = termshark
+ makedepends = python-igraph
+ makedepends = python-setuptools
+ makedepends = python-pyndn
+ depends = boost
+ provides = mini-ndn
+ conflicts = mini-ndn
+ source = https://github.com/named-data/mini-ndn/archive/v0.4.0.tar.gz
+ sha256sums = a6abcbe022b12c540584164ab68aa69192d4e15996861df1e16fda30884f60ce
+
+pkgname = mini-ndn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54f46d8b430a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+_reponame=mini-ndn
+_pkgname=mini-ndn
+pkgname=${_pkgname}
+pkgver=0.4.0
+pkgrel=1
+# epoch=
+pkgdesc="Lightweight networking emulation tool that enables testing, experimentation, and research on the NDN platform based on Mininet"
+arch=('i686' 'x86_64')
+url="https://github.com/named-data/${_reponame}"
+license=('GPL')
+groups=()
+depends=('boost')
+makedepends=('boost' 'ndn-cxx' 'ndn-nfd' 'ndn-chronosync' 'ndn-tools' 'ndn-nlsr' 'ndn-infoedit' 'mininet-git' 'termshark' 'python-igraph' 'python-setuptools' 'python-pyndn')
+checkdepends=()
+optdepends=()
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=(https://github.com/named-data/${_reponame}/archive/v${pkgver}.tar.gz)
+noextract=()
+sha256sums=('a6abcbe022b12c540584164ab68aa69192d4e15996861df1e16fda30884f60ce')
+validpgpkeys=()
+
+build() {
+ cd "${srcdir}/${_reponame}-${pkgver}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_reponame}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}