summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2021-03-21 18:20:23 -0400
committerneeshy2021-03-21 18:20:23 -0400
commit45dc458f15a9eb098d6b7b3f206fbe8931647ba7 (patch)
tree99b0428a1713218eae7c77ef7889f97cca78d73f
parent01c331a89bd6e05b700461e42b178082c6144c59 (diff)
downloadaur-45dc458f15a9eb098d6b7b3f206fbe8931647ba7.tar.gz
ripme-git: use alternative upstream
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b90cb1dbff49..e54524163362 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,10 +7,11 @@ pkgbase = ripme-git
license = MIT
makedepends = git
makedepends = maven
+ makedepends = jq
depends = java-runtime
provides = ripme
conflicts = ripme
- source = git+https://github.com/RipMeApp/ripme.git
+ source = git+https://github.com/ripmeapp2/ripme.git
sha256sums = SKIP
pkgname = ripme-git
diff --git a/PKGBUILD b/PKGBUILD
index 864c4cac9cc8..cf3aa1d12bbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@ arch=('any')
url="https://github.com/RipMeApp/ripme"
license=('MIT')
depends=('java-runtime')
-makedepends=('git' 'maven')
+makedepends=('git' 'maven' 'jq')
provides=('ripme')
conflicts=('ripme')
-source=("git+https://github.com/RipMeApp/ripme.git")
+source=("git+https://github.com/ripmeapp2/ripme.git")
sha256sums=('SKIP')
pkgver() {
@@ -32,7 +32,7 @@ EOF
package() {
cd "$srcdir/$_pkgname"
- install -Dm644 "target/ripme-$(git describe --tags --abbrev=0)-jar-with-dependencies.jar" \
+ install -Dm644 "target/ripme-$(jq -r '.latestVersion' < ripme.json)-jar-with-dependencies.jar" \
"$pkgdir/usr/share/java/ripme.jar"
install -Dm755 ripme.sh "$pkgdir/usr/bin/ripme"
}