summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoey Darwish Dror2019-01-22 13:55:36 +0200
committerRoey Darwish Dror2019-01-22 13:55:36 +0200
commit46122f89271fe562f09540702d474e6043781e98 (patch)
tree187eb3584ffbf338be3402b693252dff6b8be342
parent92d9001fea27a113260c7b316f4fa893f9f54587 (diff)
downloadaur-46122f89271fe562f09540702d474e6043781e98.tar.gz
Don't use a special variable in the update script
-rwxr-xr-xupdate.fish6
1 files changed, 3 insertions, 3 deletions
diff --git a/update.fish b/update.fish
index b5ef1f1f2b51..efd6d24bf4c9 100755
--- a/update.fish
+++ b/update.fish
@@ -1,9 +1,9 @@
#!/usr/bin/env fish
-set version $argv[1]
-set hash (string sub -l 64 (curl -L https://github.com/r-darwish/topgrade/archive/v$version.tar.gz ^/dev/null | sha256sum))
+set -l package_version $argv[1]
+set -l hash (string sub -l 64 (curl -L https://github.com/r-darwish/topgrade/archive/v$package_version.tar.gz ^/dev/null | sha256sum))
sed -E "s/sha256sums=.*\$/sha256sums=\('$hash'\)/g" -i PKGBUILD
-sed -E "s/pkgver=.*\$/pkgver=$version/g" -i PKGBUILD
+sed -E "s/pkgver=.*\$/pkgver=$package_version/g" -i PKGBUILD
makepkg --printsrcinfo > .SRCINFO
makepkg