summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-05-15 16:04:36 +0200
committersL1pKn072019-05-15 16:04:36 +0200
commit4638b4664793fe63588f03966bf0730169310ee7 (patch)
tree3c6edc5bf2ffcc762a0e649563003eec7764efbd
downloadaur-4638b4664793fe63588f03966bf0730169310ee7.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2718e32022ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vapoursynth-plugin-median-git
+ pkgdesc = Plugin for Vapoursynth: median (Fork)(GIT version)
+ pkgver = v4.0.g9a2065c
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-median
+ arch = x86_64
+ license = unknown
+ makedepends = mercurial
+ depends = vapoursynth
+ provides = vapoursynth-plugin-median
+ provides = vapoursynth-plugin-median-hg
+ conflicts = vapoursynth-plugin-median
+ conflicts = vapoursynth-plugin-median-hg
+ source = median::git+https://github.com/dubhater/vapoursynth-median.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-median-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78b56b82ba2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=median
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v4.0.g9a2065c
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (Fork)(GIT version)"
+arch=('x86_64')
+url='https://github.com/dubhater/vapoursynth-median'
+license=('unknown')
+depends=('vapoursynth')
+makedepends=('mercurial')
+provides=("vapoursynth-plugin-${_plug}"
+ "vapoursynth-plugin-${_plug}-hg"
+ )
+conflicts=("vapoursynth-plugin-${_plug}"
+ "vapoursynth-plugin-${_plug}-hg"
+ )
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-median.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+
+# install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}