summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Schindler2017-12-11 10:37:02 +0000
committerFelix Schindler2017-12-11 10:47:06 +0000
commit4641abe4213c143649c68cce548eb356f32873d0 (patch)
tree4a6c00f898e1b6439617534ecd72de24cce0ac0e
downloadaur-4641abe4213c143649c68cce548eb356f32873d0.tar.gz
3.12.0-1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8bf45a4c103
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Dec 11 10:46:09 UTC 2017
+pkgbase = valgrind312
+ pkgdesc = A tool to help find memory-management problems in programs (version 3.12.0)
+ pkgver = 3.12.0
+ pkgrel = 1
+ url = http://valgrind.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gdb
+ makedepends = openmpi
+ depends = glibc=2.26
+ depends = perl
+ optdepends = openmpi: MPI support
+ provides = valgrind=3.12.0
+ conflicts = valgrind
+ replaces = valgrind
+ options = !emptydirs
+ source = http://valgrind.org/downloads/valgrind-3.12.0.tar.bz2
+ sha1sums = 7a6878bf998c60d1e377a4f22ebece8d9305bda4
+
+pkgname = valgrind312
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8586867e2054
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Felix Schindler <aur at felixschindler dot net>
+# Contributor: Dan McGee <dan@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+#
+# There is a bug in valgrind 3.13 which arises when used from qtcreater, see
+# https://stackoverflow.com/questions/45531851/valgrind-in-qt-creator#45551442
+
+pkgname=valgrind312
+_pkgname=valgrind
+pkgver=3.12.0
+pkgrel=1
+pkgdesc='A tool to help find memory-management problems in programs (version 3.12.0)'
+arch=(i686 x86_64)
+license=(GPL)
+url='http://valgrind.org/'
+depends=('glibc=2.26' 'perl')
+makedepends=(gdb openmpi)
+optdepends=('openmpi: MPI support')
+options=(!emptydirs)
+source=(http://valgrind.org/downloads/$_pkgname-$pkgver.tar.bz2)
+sha1sums=('7a6878bf998c60d1e377a4f22ebece8d9305bda4')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("$_pkgname")
+replaces=("$_pkgname")
+
+build() {
+ # valgrind does not like stack protector flags
+ CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
+ CFLAGS=${CFLAGS/-fstack-protector-strong/}
+ CXXFLAGS=${CXXFLAGS/-fstack-protector-strong/}
+
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --mandir=/usr/share/man --with-mpicc=mpicc
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}