summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-08-25 18:31:54 +0300
committerStelios Tsampas2023-08-25 18:31:54 +0300
commit4643a7bc7b6360739fea503e1a059506aab19d2b (patch)
tree7eb14b3d2134fde4a11217a5ec3ad862a98b21d8
parent7f706a7ed89fe686e119c972f71a18dbab90c903 (diff)
downloadaur-4643a7bc7b6360739fea503e1a059506aab19d2b.tar.gz
[ppsspp-git] Add aarch64
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
-rw-r--r--PKGBUILD.testing4
3 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 968a30e120c6..41e8c2a58490 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = ppsspp-git
pkgrel = 1
url = https://www.ppsspp.org/
arch = x86_64
+ arch = aarch64
license = GPL2
makedepends = clang
makedepends = lld
diff --git a/PKGBUILD b/PKGBUILD
index 4959ee210a39..72e624823e51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgname=(
pkgver=1.15.4.r1211.308e983a99
pkgrel=1
pkgdesc='A PSP emulator written in C++'
-arch=(x86_64)
+arch=(x86_64 aarch64)
url=https://www.ppsspp.org/
license=(GPL2)
makedepends=(
@@ -102,6 +102,9 @@ build() {
x86_64)
./linux_x86-64.sh
;;
+ aarch64)
+ ./linux_arm64_native.sh
+ ;;
esac
popd
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index fca6e578bc02..ed8e2e4b3e0b 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -54,7 +54,7 @@ source=(
ppsspp-qt.desktop
)
source_x86_64=(
- ppsspp-ffmpeg_x86_64.sh::https://raw.githubusercontent.com/hrydgard/ppsspp-ffmpeg/master/linux_x86-64.sh
+ ppsspp-ffmpeg_x86-64.sh::https://raw.githubusercontent.com/hrydgard/ppsspp-ffmpeg/master/linux_x86-64.sh
)
b2sums=('SKIP'
'SKIP'
@@ -112,7 +112,7 @@ build() {
pushd ppsspp/ffmpeg
case "$CARCH" in
x86_64)
- ./ppsspp-ffmpeg_x86_64.sh
+ ./ppsspp-ffmpeg_x86-64.sh
;;
esac
popd