summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredchenjs2019-07-14 00:34:21 +0800
committerredchenjs2019-07-14 00:34:21 +0800
commit464fe61eec580c6cb53557057cecd83cc370596f (patch)
tree4c5d9ce32ece88448c3cd56bdf1751149afe6d0d
downloadaur-464fe61eec580c6cb53557057cecd83cc370596f.tar.gz
init commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed6b52ab284d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = adobe-source-han-classic-fonts
+ pkgdesc = Adobe Source Han Fonts with Classic Style Chinese Character
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/adobe-fonts/
+ arch = any
+ license = OFL
+ source = https://github.com/redchenjs/source-han-serif-classic/raw/master/OTC/SourceHanSerifC.otc
+ source = https://github.com/redchenjs/source-han-sans-classic/raw/master/OTC/SourceHanSansC.otc
+ source = https://github.com/redchenjs/source-han-mono-classic/raw/master/OTC/SourceHanMonoC.otc
+ md5sums = 9ae3d2c20547a0ce31bdbf7d938075d7
+ md5sums = 92d6b46fb5133569ccf3c7bf7d6c6b1d
+ md5sums = e8e38cd189bc3f4fcce8306fd5f0492b
+
+pkgname = adobe-source-han-classic-fonts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a7b8f64b98ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93b4bd569ed1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jack Chen <redchenjs@live.com>
+
+pkgname=adobe-source-han-classic-fonts
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Adobe Source Han Fonts with Classic Style Chinese Character"
+arch=('any')
+url="https://github.com/adobe-fonts/"
+license=('OFL')
+source=(
+ 'https://github.com/redchenjs/source-han-serif-classic/raw/master/OTC/SourceHanSerifC.otc'
+ 'https://github.com/redchenjs/source-han-sans-classic/raw/master/OTC/SourceHanSansC.otc'
+ 'https://github.com/redchenjs/source-han-mono-classic/raw/master/OTC/SourceHanMonoC.otc'
+)
+md5sums=(
+ '9ae3d2c20547a0ce31bdbf7d938075d7'
+ '92d6b46fb5133569ccf3c7bf7d6c6b1d'
+ 'e8e38cd189bc3f4fcce8306fd5f0492b'
+)
+
+package() {
+ install -Dm644 "${srcdir}"/SourceHanSerifC.otc \
+ "${pkgdir}"/usr/share/fonts/adobe-source-han-classic/SourceHanSerifC.otc
+ install -Dm644 "${srcdir}"/SourceHanSansC.otc \
+ "${pkgdir}"/usr/share/fonts/adobe-source-han-classic/SourceHanSansC.otc
+ install -Dm644 "${srcdir}"/SourceHanMonoC.otc \
+ "${pkgdir}"/usr/share/fonts/adobe-source-han-classic/SourceHanMonoC.otc
+}