summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Bell2015-10-22 03:00:21 -0400
committerStephen Bell2015-10-22 03:00:21 -0400
commit4673a03e4a9445a5981a3cd7b1a10dd552e6477d (patch)
treec3ef455d95b7c3ad7efe1c68b9762ec650aec420
downloadaur-4673a03e4a9445a5981a3cd7b1a10dd552e6477d.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25ff0e26f9f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = destinationsol
+ pkgdesc = 2D Space Arcade/RPG with Planets
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/MovingBlocks/DestinationSol
+ arch = i686
+ arch = x86_64
+ license = Apache V2
+ makedepends = unzip
+ depends = java-runtime-common
+
+pkgname = destinationsol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9361a2229aee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Stephen Bell <theredbaron1834 @ yahoo.com>
+pkgname=destinationsol
+pkgrel=1
+pkgver=1.3.1
+pkgdesc="2D Space Arcade/RPG with Planets"
+arch=('i686' 'x86_64')
+url="https://github.com/MovingBlocks/DestinationSol"
+license=('Apache V2')
+depends=('java-runtime-common')
+makedepends=('unzip')
+
+build() {
+ mkdir "$srcdir/DestinationSol"
+ cd "$srcdir"/DestinationSol
+ msg "Grabbing files...."
+ curl https://github.com/MovingBlocks/DestinationSol/releases/download/v1.3.1/DestinationSol.zip -L -o DestinationSol.zip
+ unzip DestinationSol.zip
+}
+
+package() {
+ cd "$pkgdir"
+install -m777 -d "$pkgdir/opt/DestinationSol"
+ cp -r "$srcdir/DestinationSol/libs" "$pkgdir/opt/DestinationSol/"
+ cp -r "$srcdir/DestinationSol/res" "$pkgdir/opt/DestinationSol/"
+ mkdir -p "$pkgdir/usr/share/applications/"
+ mkdir -p "$pkgdir/usr/bin/"
+ echo "[Desktop Entry]
+Name=Destination Sol
+GenericName=Destination Sol
+Comment=2D Space Arcade/RPG with Planets
+Exec=DestinationSol
+Icon=/opt/DestinationSol/res/icon.png
+Terminal=false
+Type=Application
+Categories=Game;" > "$pkgdir/usr/share/applications/DestinationSol.desktop"
+ echo "cd /opt/DestinationSol/
+java -jar /opt/DestinationSol/libs/solDesktop.jar" > "$pkgdir/usr/bin/DestinationSol"
+ chmod +x "$pkgdir/usr/bin/DestinationSol"
+}
+