summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-10 21:10:42 +0200
committerMarcell Meszaros2022-07-10 21:10:42 +0200
commit469d226670916334c5e79d28ed91a6d4b390692f (patch)
tree15184903f589e58d28fc6a93af4b85883b7c06a5
parentf0ea2fc2c4f7d728f455720c2d890522f4241923 (diff)
downloadaur-469d226670916334c5e79d28ed91a6d4b390692f.tar.gz
2.7a1-3: set compatible Python3 version range
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cb9b0b34f28..cb988c36be9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-pycrypto
pkgdesc = [DEPRECATED since 2013] Cryptographic primitives and algorithms for Python
pkgver = 2.7a1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pycrypto/pycrypto/blob/master/README.md
arch = x86_64
license = custom:Unlicense
license = PSF
makedepends = gmp
makedepends = python-setuptools
+ depends = python>=3.3
+ depends = python<3.9
conflicts = python-pycryptodome
source = pycrypto-2.7a1.tar.gz::https://github.com/pycrypto/pycrypto/archive/refs/tags/v2.7a1.tar.gz
source = 0001-replaced-time.clock-with-time.process_time-time-cloc.patch
@@ -21,4 +23,3 @@ pkgname = python-pycrypto
pkgname = python-crypto
depends = gmp
- depends = python
diff --git a/PKGBUILD b/PKGBUILD
index a572b02bf26b..3197c1366134 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,15 @@ pkgbase='python-pycrypto'
pkgname=('python-pycrypto' 'python-crypto')
_name="${pkgbase#python-}"
pkgver=2.7a1
-pkgrel=2
+pkgrel=3
pkgdesc='[DEPRECATED since 2013] Cryptographic primitives and algorithms for Python'
arch=('x86_64')
_repourl="https://github.com/${_name}/${_name}"
url="${_repourl}/blob/master/README.md"
license=('custom:Unlicense' 'PSF')
+depends=(
+ 'python>=3.3'
+ 'python<3.9')
makedepends=(
'gmp'
'python-setuptools'
@@ -40,10 +43,7 @@ package_python-pycrypto() {
}
package_python-crypto() {
- depends=(
- 'gmp'
- 'python'
- )
+ depends=('gmp')
cd "${_tarname}"
python setup.py install --root="${pkgdir}" --prefix='/usr' --optimize=1 --skip-build