summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreizh2017-01-06 21:16:52 +0100
committerBreizh2017-01-06 21:16:52 +0100
commit46a42522cc9618aa90625f4c927cd87fc4131e0d (patch)
treebfe87f4655ba7e3d7c0169f20de470cc6c56f47d
parent82773f230552796dafb95f5b54d80775e4e8d069 (diff)
downloadaur-46a42522cc9618aa90625f4c927cd87fc4131e0d.tar.gz
Upgrade to 2.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
2 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0e268f3182e..30b3964fd736 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
-# Generated by mksrcinfo v8
-# Tue Sep 13 11:46:11 UTC 2016
pkgbase = p7
- pkgdesc = Transfer files in and out of your CASIO fx calculator through USB
- pkgver = 1.4
- pkgrel = 2
+ pkgdesc = Casio Communication Protocol 7.00 implementation
+ pkgver = 2.0
+ pkgrel = 1
url = https://p7.touhey.fr/
arch = i686
arch = x86_64
license = GPL2
- makedepends = make
- makedepends = asciidoc
- makedepends = gzip
- depends = libp7>=1.5-1
- source = https://forge.touhey.fr/casio/software/p7/snapshot/p7-1.4.tar.gz
- md5sums = 554cb0d4a77a79d48c48fe797e5b2338
+ makedepends = make>=4.0
+ makedepends = gcc>=4.9
+ makedepends = asciidoc>=8.6.9
+ makedepends = gzip>=1.6
+ makedepends = binutils>=2.25
+ makedepends = libp7>=2.0
+ depends = libusb>=1.0
+ source = https://p7.touhey.fr/pub/p7utils-2.0.tar.gz
+ md5sums = 66d2407ee3c7f9b79bc11e7b6cd2a726
pkgname = p7
diff --git a/PKGBUILD b/PKGBUILD
index 129e6aca227e..7d6eee8d837c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer : Breizh <breizh.craft.98@openmailbox.org>
pkgname=p7
-pkgver=1.4
-pkgrel=2
-pkgdesc="Transfer files in and out of your CASIO fx calculator through USB"
+pkgver=2.0
+pkgrel=1
+pkgdesc="Casio Communication Protocol 7.00 implementation"
arch=('i686' 'x86_64')
url="https://p7.touhey.fr/"
license=('GPL2')
groups=()
-depends=('libp7>=1.5-1')
-makedepends=('make' 'asciidoc' 'gzip')
+depends=('libusb>=1.0')
+makedepends=('make>=4.0' 'gcc>=4.9' 'asciidoc>=8.6.9' 'gzip>=1.6' 'binutils>=2.25' 'libp7>=2.0')
optdepends=()
provides=()
conflicts=()
@@ -17,19 +17,16 @@ backup=()
options=()
install=
changelog=
-source=(https://forge.touhey.fr/casio/software/$pkgname/snapshot/$pkgname-$pkgver.tar.gz)
+source=(https://p7.touhey.fr/pub/p7utils-${pkgver}.tar.gz)
noextract=()
-md5sums=('554cb0d4a77a79d48c48fe797e5b2338')
+md5sums=('66d2407ee3c7f9b79bc11e7b6cd2a726')
build() {
- cd "$pkgname-$pkgver"
-
- ./configure --root=$pkgdir
- make
+ cd "p7utils-$pkgver"
+ ./configure && make all-p7
}
package() {
- cd "$pkgname-$pkgver"
-
- make install
+ cd "p7utils-$pkgver"
+ make install-p7 DESTDIR="$pkgdir"
}