summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-03-08 14:08:15 -0300
committerDaniel Bermond2022-03-08 14:08:15 -0300
commit46a6baf0cc012b24eb2b0f74253f54e53b248c5d (patch)
tree9adc1e3f143f91d820391fe25de24a7c639a6aa8
parent1394e322e7c15d96d980eebf66f9f953dc06ad23 (diff)
downloadaur-46a6baf0cc012b24eb2b0f74253f54e53b248c5d.tar.gz
Disable lto to match repository package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d06697cbfec..665dc8746cfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-git
pkgdesc = A compatibility layer for running Windows programs (git version)
- pkgver = 6.22.r0.g986254d6c17
+ pkgver = 7.3.r297.g99ef287bb72
pkgrel = 1
url = https://www.winehq.org/
install = wine-git.install
@@ -138,14 +138,15 @@ pkgbase = wine-git
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=6.22.r0.g986254d6c17
- provides = bin32-wine=6.22.r0.g986254d6c17
- provides = wine-wow64=6.22.r0.g986254d6c17
+ provides = wine=7.3.r297.g99ef287bb72
+ provides = bin32-wine=7.3.r297.g99ef287bb72
+ provides = wine-wow64=7.3.r297.g99ef287bb72
conflicts = wine
conflicts = bin32-wine
conflicts = wine-wow64
replaces = bin32-wine
options = staticlibs
+ options = !lto
source = git://source.winehq.org/git/wine.git
source = 30-win32-aliases.conf
source = wine-binfmt.conf
diff --git a/PKGBUILD b/PKGBUILD
index bd65df5b9e4c..9f791054b6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: sxe <sxxe@gmx.de>
pkgname=wine-git
-pkgver=6.22.r0.g986254d6c17
+pkgver=7.3.r297.g99ef287bb72
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (git version)'
arch=('x86_64')
@@ -84,7 +84,7 @@ optdepends=(
'samba'
'dosbox'
)
-options=('staticlibs')
+options=('staticlibs' '!lto')
install="${pkgname}.install"
provides=("wine=${pkgver}" "bin32-wine=${pkgver}" "wine-wow64=${pkgver}")
conflicts=('wine' 'bin32-wine' 'wine-wow64')
@@ -112,9 +112,7 @@ pkgver() {
}
build() {
- # workaround for FS#55128
- # https://bugs.archlinux.org/task/55128
- # https://bugs.winehq.org/show_bug.cgi?id=43530
+ # does not compile without remove these flags as of 4.10
export CFLAGS="${CFLAGS/-fno-plt/}"
export LDFLAGS="${LDFLAGS/,-z,now/}"