summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2016-12-24 18:18:31 -0500
committersolaraquarion2016-12-24 18:18:31 -0500
commit46c9e1b323b3521981d5796f4e2a9c91eceddf46 (patch)
tree2bc1567c758b3cc5675644bdab2da3c1b27beee1
parent17dcae8b18e28811f5545e70b41a667646404bac (diff)
downloadaur-46c9e1b323b3521981d5796f4e2a9c91eceddf46.tar.gz
updating
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--vlc30
3 files changed, 40 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e9c408f91ff..1e7573af174f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 9 17:03:44 UTC 2016
+# Sat Dec 24 23:18:20 UTC 2016
pkgbase = vlc-nightly
pkgdesc = A multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot
- pkgver = 3.0.0v20161209
+ pkgver = 3.0.0v20161224
pkgrel = 1
url = http://www.videolan.org/vlc/
arch = i686
@@ -59,6 +59,7 @@ pkgbase = vlc-nightly
depends = libmodplug
depends = libass
depends = xcb-util-keysyms
+ depends = libpthread-stubs
optdepends = avahi: for service discovery using bonjour protocol
optdepends = libnotify: for notification plugin
optdepends = ncurses: for ncurses interface support
@@ -97,10 +98,10 @@ pkgbase = vlc-nightly
options = !libtool
options = !emptydirs
options = debug
- source = http://nightlies.videolan.org/build/source/vlc-3.0.0-20161209-0236-git.tar.xz
+ source = http://nightlies.videolan.org/build/source/vlc-3.0.0-20161224-0237-git.tar.xz
source = update-vlc-plugin-cache.hook
source = https://git.archlinux.org/svntogit/packages.git/plain/trunk/lua53_compat.patch?h=packages/vlc
- sha1sums = 766c892a151191ec7599794d63b2f1bc3b36760a
+ sha1sums = b06432fee063cf6a71fde574dc26d2718cab55bc
sha1sums = c3a35ba4dbd6c8e4e5b032664f50b9f0dcf579ee
sha1sums = 5d7dba23756ff577a90b8631b187fbeac1f94e17
diff --git a/PKGBUILD b/PKGBUILD
index fa3b7ce1f8b8..7566d1c75861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
_appname_=vlc
pkgname=${_appname_}-nightly
-pkgver=3.0.0v20161209
+pkgver=3.0.0v20161224
_pkgver=3.0.0
-_snapshot_=20161209
-_snapver_=0236
+_snapshot_=20161224
+_snapver_=0237
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot"
@@ -18,7 +18,7 @@ depends=("a52dec" "libdvbpsi" "libxpm" "libdca" "qt5-base" "libproxy"
"sdl_image" "libdvdnav" "libtiger" "lua" "libmatroska"
"zvbi" "taglib" "libmpcdec" "ffmpeg" "faad2" "libupnp"
"libshout" "libmad" "directfb" "libmpeg2" "libmodplug" "libass"
- "xcb-util-keysyms")
+ "xcb-util-keysyms" "libpthread-stubs")
makedepends=("live-media" "libnotify" "libbluray" "flac" "kdelibs4support"
"fluidsynth" "libdc1394" "libavc1394" "lirc-utils"
"libcaca" "librsvg" "portaudio" "libgme" "xosd"
@@ -112,6 +112,6 @@ package() {
install -Dm644 "$srcdir"/update-vlc-plugin-cache.hook "$pkgdir"/usr/share/libalpm/hooks/update-vlc-plugin-cache.hook
}
-sha1sums=('766c892a151191ec7599794d63b2f1bc3b36760a'
+sha1sums=('b06432fee063cf6a71fde574dc26d2718cab55bc'
'c3a35ba4dbd6c8e4e5b032664f50b9f0dcf579ee'
'5d7dba23756ff577a90b8631b187fbeac1f94e17')
diff --git a/vlc b/vlc
new file mode 100644
index 000000000000..aeff7b2fd778
--- /dev/null
+++ b/vlc
@@ -0,0 +1,30 @@
+commit 41caaa08cde60c4fec4bf2e5f9610e2a1b9e6a23
+Author: Vinson Lee <vlee@freedesktop.org>
+Date: Thu Feb 5 14:48:53 2015 -0800
+
+ lua: Define LUA_COMPAT_APIINTCASTS for Lua >= 5.3.0 compatibility.
+
+ In Lua 5.3.0, luaL_checkint was deprecated.
+
+ This patch fixes this build error with Lua 5.3.0.
+
+ lua/demux.c: In function ‘vlclua_demux_peek’:
+ lua/demux.c:55:5: error: implicit declaration of function ‘luaL_checkint’ [-Werror=implicit-function-declaration]
+ int n = luaL_checkint( L, 1 );
+ ^
+
+ Signed-off-by: Vinson Lee <vlee@freedesktop.org>
+ Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
+
+diff --git a/modules/lua/vlc.h b/modules/lua/vlc.h
+index efd94f1..85c7fc1 100644
+--- a/modules/lua/vlc.h
++++ b/modules/lua/vlc.h
+@@ -38,6 +38,7 @@
+ #include <vlc_stream.h>
+ #include <vlc_demux.h>
+
++#define LUA_COMPAT_APIINTCASTS
+ #define LUA_COMPAT_MODULE
+ #include <lua.h> /* Low level lua C API */
+ #include <lauxlib.h> /* Higher level C API */