summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2021-11-04 09:02:01 +0100
committerfordprefect2021-11-04 09:02:01 +0100
commit46fa93f2946fed9240b5680092ebd0bc0ae12a8a (patch)
tree3ad9807b771fb9c3e86f9a0f7e02b76530d678e7
parentdf866d3f2845d0e9590b6bc192848b326c35c4be (diff)
downloadaur-46fa93f2946fed9240b5680092ebd0bc0ae12a8a.tar.gz
add missing dependency, add license file
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5a20d2979d4..4fc7f1cc6314 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
pkgname=python-symfit
pkgver=0.5.4
-pkgrel=1
+pkgrel=2
pkgdesc='Symbolic fitting for python - fitting as it should be'
arch=('any')
url='https://github.com/tBuLi/symfit'
-depends=('python' 'python-numpy' 'python-sympy')
+depends=('python' 'python-numpy' 'python-sympy' 'python-toposort')
makedepends=('python-setuptools')
license=('MIT')
source=("$pkgname-$pkgver.tar.gz::https://github.com/tBuLi/symfit/archive/$pkgver.tar.gz")
@@ -13,4 +13,6 @@ md5sums=('fc2a6606d1ddf511524e03153799a2d0')
package() {
cd "$srcdir/symfit-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -D "$srcdir/symfit-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}