summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Stubbs2018-04-12 21:24:17 +0000
committerAndrew Stubbs2018-04-12 21:44:26 +0000
commit470d4b48ed3af0a94aab5f7995bf6295f1e1e0a8 (patch)
tree5fd9b283c37311ee85b6c968fc107d2ae34aab2e
parent24f0969c21b7e6a1fc00ce01cd3d8e92300af2a7 (diff)
downloadaur-470d4b48ed3af0a94aab5f7995bf6295f1e1e0a8.tar.gz
Change to etcher-bin.
Also add /usr/bin/etcher-electron
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--etcher8
3 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89fd23403f6f..bb5913808c3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,4 @@
-# Generated by mksrcinfo v8
-# Wed Jan 24 09:43:52 UTC 2018
-pkgbase = etcher
+pkgbase = etcher-bin
pkgdesc = Burn images to SD cards & USB drives, safe & easy
pkgver = 1.3.1
pkgrel = 1
@@ -15,9 +13,11 @@ pkgbase = etcher
depends = alsa-lib
optdepends = libnotify: for notifications
optdepends = speech-dispatcher: for text-to-speech
+ provides = etcher
+ conflicts = etcher
options = !strip
source_x86_64 = https://github.com/resin-io/etcher/releases/download/v1.3.1/etcher-electron_1.3.1_amd64.deb
sha256sums_x86_64 = 366a083b6009ae75830fd920a947812ab9c7ec3a2039dc1b8524d28640b8179d
-pkgname = etcher
+pkgname = etcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5f7da986f627..b31324f29b61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Andrew Stubbs <andrew.stubbs@gmail.com>
-pkgname=etcher
+pkgname=etcher-bin
_realver=1.3.1
pkgver=${_realver//-/_}
pkgrel=1
@@ -7,6 +7,8 @@ pkgdesc="Burn images to SD cards & USB drives, safe & easy"
arch=('x86_64')
url="http://www.etcher.io/"
license=('apache')
+provides=('etcher')
+conflicts=('etcher')
depends=('gtk2' 'libxtst' 'libxss' 'gconf' 'nss' 'alsa-lib')
optdepends=('libnotify: for notifications'
'speech-dispatcher: for text-to-speech')
@@ -18,4 +20,7 @@ sha256sums_x86_64=('366a083b6009ae75830fd920a947812ab9c7ec3a2039dc1b8524d28640b8
package() {
cd "$pkgdir"
tar xf "$srcdir/data.tar.xz"
+
+ mkdir -p usr/bin
+ ln -s /opt/Etcher/etcher-electron usr/bin
}
diff --git a/etcher b/etcher
deleted file mode 100644
index 4247e2dc50f9..000000000000
--- a/etcher
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-# Prevent the AppImage prompting the user to create a Desktop file
-# in ~/.local when we already have one in /usr/share.
-DESKTOPINTEGRATION=no
-export DESKTOPINTEGRATION
-
-exec /usr/share/etcher/Etcher-$realver-linux-$a.appimage