summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-07-04 21:35:41 +0200
committerPellegrino Prevete2023-07-04 21:35:41 +0200
commit4715c194dc3770edf3ba14fefbed88b8700781d1 (patch)
treeeb8426012b3fab0777e7755c59b7871ca2d3dbd0
parenta25a9facb82db565abe941f17ae65f112a740d62 (diff)
downloadaur-4715c194dc3770edf3ba14fefbed88b8700781d1.tar.gz
upgrade to 0.12.5
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD36
2 files changed, 26 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83d17d029645..7aba0781a88c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python2-quantities
pkgdesc = Support for physical quantities with units, based on numpy
- pkgver = 0.12.4
+ pkgver = 0.12.5
pkgrel = 1
url = https://pypi.org/project/quantities/#files
arch = any
license = BSD
makedepends = python2-setuptools
makedepends = python2-numpy
- source = https://files.pythonhosted.org/packages/source/q/quantities/quantities-0.12.4.tar.gz
- sha256sums = a33d636d1870c9e1127631185d89b0105a49f827d6aacd44ad9d8f151f331d8b
+ source = https://files.pythonhosted.org/packages/source/q/quantities/quantities-0.12.5.tar.gz
+ sha256sums = 67546963cb2a519b1a4aa43d132ef754360268e5d551b43dd1716903d99812f0
pkgname = python2-quantities
depends = python2
-
diff --git a/PKGBUILD b/PKGBUILD
index a374864ee9ed..0d5647c87f36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,33 @@
-# Maintainer: Sergio Davies <sergio dot newsletter at gmail dot com>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Contributor: Sergio Davies <sergio dot newsletter at gmail dot com>
-pkgbase=python2-quantities
-pkgname=('python2-quantities')
-_name=${pkgbase#python2-}
-pkgver=0.12.4
+_py="python2"
+_pkg="quantities"
+pkgbase="${_py}-${_pkg}"
+pkgname=("${pkgbase}")
+pkgver=0.12.5
pkgrel=1
pkgdesc="Support for physical quantities with units, based on numpy"
arch=('any')
-url="https://pypi.org/project/quantities/#files"
+url="https://pypi.org/project/${_pkg}/#files"
license=('BSD')
-makedepends=('python2-setuptools'
- 'python2-numpy')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('a33d636d1870c9e1127631185d89b0105a49f827d6aacd44ad9d8f151f331d8b')
+makedepends=(
+ "${_py}-setuptools"
+ "${_py}-numpy"
+)
+_pypi_url="https://files.pythonhosted.org/packages/source"
+source=(
+ "${_pypi_url}/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz"
+)
+sha256sums=(
+ '67546963cb2a519b1a4aa43d132ef754360268e5d551b43dd1716903d99812f0'
+)
package_python2-quantities() {
- depends+=('python2')
+ depends+=("${_py}")
- cd "${srcdir}/${_name}-${pkgver}"
- python2 setup.py install --root="${pkgdir}"
+ cd "${_pkg}-${pkgver}"
+ "${_py}" setup.py install --root="${pkgdir}"
}
+# vim:set sw=2 sts=-1 et: