summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2019-01-04 23:39:32 -0500
committerredfish2019-01-04 23:39:32 -0500
commit4718c060fce8bf3f332c342ed03663813c915b08 (patch)
tree842442aa4d29562d15eb8ee9671c6f4522021207
parent5c60f8b6df7c3e328f453f2b87b21f2f0353ffb8 (diff)
downloadaur-4718c060fce8bf3f332c342ed03663813c915b08.tar.gz
update to 1.2.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--config.patch13
-rw-r--r--no-inline.patch85
-rw-r--r--policy.patch16
5 files changed, 23 insertions, 134 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d5fa012c14f..a3badee6396f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 14 04:36:52 UTC 2018
+# Sat Jan 5 04:38:47 UTC 2019
pkgbase = mgetty
pkgdesc = Mgetty is a versatile program to handle all aspects of a modem under Unix.
- pkgver = 1.1.37
- pkgrel = 5
+ pkgver = 1.2.1
+ pkgrel = 1
url = http://mgetty.greenie.net/
install = mgetty.install
arch = i686
@@ -15,19 +15,17 @@ pkgbase = mgetty
depends = logrotate
depends = udev
depends = netpbm
- source = ftp://mgetty.greenie.net/pub/mgetty/source/1.1/mgetty1.1.37-Jun05.tar.gz
+ source = ftp://mgetty.greenie.net/pub/mgetty/source/1.2/mgetty-1.2.1.tar.gz
source = Makefile.patch
source = config.patch
source = policy.patch
- source = no-inline.patch
source = aarch64.patch
source = 90-mgetty.rules
source = mgetty@.service
- md5sums = 4df2eb47bd6d5318d3d642572ab56e51
+ md5sums = 41a18c46845ff058d2848bc1aab6ab3b
md5sums = eaa2b17d77ca099ebb7e92cf2006f6c1
- md5sums = d40de3f241a2851f091e0046cb7f28c0
- md5sums = 5556e5e88c784e75acb14ab998d7eb1a
- md5sums = 4291e988c7e15c1e93ac86b6efe5818b
+ md5sums = c0f9ed08a1e9877f972cbd8a00cfd932
+ md5sums = 2b33cdaa32ec79bb4bfe67bc0a8f2a32
md5sums = 8756ace492fb86ba70ed3a5c4b980b0b
md5sums = 4b73a5654db86a34a8dccdf5f55c699c
md5sums = cbc70329924235e8f2e6302c859d59a6
diff --git a/PKGBUILD b/PKGBUILD
index e9fb91c832d4..d35ddfffa6bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Deon Spengler <deon.spengler@gmail.com>
# Contributor: Dieter Rethmeyer <Dieter@rethmeyers.de>
pkgname=mgetty
-pkgver=1.1.37
-pkgrel=5
+pkgver=1.2.1
+pkgrel=1
pkgdesc="Mgetty is a versatile program to handle all aspects of a modem under Unix."
url="http://mgetty.greenie.net/"
license=('GPL')
@@ -10,40 +10,32 @@ arch=('i686' 'x86_64' 'aarch64')
depends=('glibc' 'logrotate' 'udev' 'netpbm')
makedepends=('make')
install=mgetty.install
-source=(ftp://mgetty.greenie.net/pub/mgetty/source/1.1/${pkgname}${pkgver}-Jun05.tar.gz
+source=(ftp://mgetty.greenie.net/pub/mgetty/source/1.2/${pkgname}-${pkgver}.tar.gz
Makefile.patch
config.patch
policy.patch
- no-inline.patch
aarch64.patch
90-mgetty.rules
mgetty@.service)
-md5sums=('4df2eb47bd6d5318d3d642572ab56e51'
- 'eaa2b17d77ca099ebb7e92cf2006f6c1'
- 'd40de3f241a2851f091e0046cb7f28c0'
- '5556e5e88c784e75acb14ab998d7eb1a'
- '4291e988c7e15c1e93ac86b6efe5818b'
- '8756ace492fb86ba70ed3a5c4b980b0b'
- '4b73a5654db86a34a8dccdf5f55c699c'
- 'cbc70329924235e8f2e6302c859d59a6')
prepare() {
cd $srcdir/$pkgname-$pkgver
cp policy.h-dist policy.h
patch -Np0 -i ../../config.patch
patch -Np0 -i ../../policy.patch
- patch -p1 < ../../no-inline.patch
patch -p1 < ../../aarch64.patch
}
build() {
cd $srcdir/$pkgname-$pkgver
- make
+ make -j1 # Makefile is broken for parallel make: sedscript not generated in time
+ chmod +x ./mkidirs
}
package() {
cd $srcdir/$pkgname-$pkgver
mkdir -p $pkgdir/var/spool
+ mkdir -p $pkgdir/usr/bin
make prefix=$pkgdir/usr spool=$pkgdir/var/spool CONFDIR=$pkgdir/etc/mgetty+sendfax FAX_OUT_USER=0 install
rm -f $pkgdir/usr/bin/g3topbm
mv $pkgdir/usr/sbin/* $pkgdir/usr/bin/
@@ -51,3 +43,10 @@ package() {
install -D -m644 $srcdir/90-mgetty.rules $pkgdir/etc/udev/rules.d/90-mgetty.rules
install -D -m644 $srcdir/mgetty@.service $pkgdir/usr/lib/systemd/system/mgetty@.service
}
+md5sums=('41a18c46845ff058d2848bc1aab6ab3b'
+ 'eaa2b17d77ca099ebb7e92cf2006f6c1'
+ 'c0f9ed08a1e9877f972cbd8a00cfd932'
+ '2b33cdaa32ec79bb4bfe67bc0a8f2a32'
+ '8756ace492fb86ba70ed3a5c4b980b0b'
+ '4b73a5654db86a34a8dccdf5f55c699c'
+ 'cbc70329924235e8f2e6302c859d59a6')
diff --git a/config.patch b/config.patch
index 2faec121eac8..e6bb5de8c908 100644
--- a/config.patch
+++ b/config.patch
@@ -1,10 +1,10 @@
--- Makefile 2007-06-15 13:15:56.000000000 +0200
-+++ ../gepatcht/Makefile 2010-01-24 23:05:15.000000000 +0100
++++ Makefile 2010-01-24 23:05:15.000000000 +0100
@@ -102,7 +102,7 @@
# USTAT - ustat(), no statfs etc.
#
#CFLAGS=-Wall -O2 -pipe -DSECUREWARE -DUSE_POLL
--CFLAGS=-O2 -Wall -pipe
+-CFLAGS=-Wall -O2 -pipe
+CFLAGS=$(RPM_OPT_FLAGS) -Wall -pipe -DAUTO_PPP
#CFLAGS=-O -DSVR4
#CFLAGS=-O -DSVR4 -DSVR42
@@ -36,12 +36,3 @@
#CONFDIR=/etc/default/
#
#
-@@ -275,7 +275,7 @@
- # please use the "mg.echo" program provided in the compat/ subdirectory.
- # Set ECHO="mg.echo" and INSTALL_MECHO to mg.echo
- #
--ECHO="echo"
-+ECHO="echo -e"
- #
- # INSTALL_MECHO=mg.echo
-
diff --git a/no-inline.patch b/no-inline.patch
deleted file mode 100644
index 1d8384e7a838..000000000000
--- a/no-inline.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-diff -U3 -r a/g3/g3cat.c b/g3/g3cat.c
---- a/g3/g3cat.c 2005-02-27 14:03:37.000000000 -0500
-+++ b/g3/g3cat.c 2018-01-13 22:38:01.598767655 -0500
-@@ -43,9 +43,6 @@
- static int b_written = 0; /* bytes of a line already */
- /* written */
-
--#ifdef __GNUC__
--inline
--#endif
- void putcode _P2( (code, len), int code, int len )
- {
- #ifdef DEBUG
-@@ -66,9 +63,6 @@
- }
- }
-
--#ifdef __GNUC__
--inline
--#endif
- void putwhitespan _P1( (l), int l )
- {
- if ( l >= 64 )
-@@ -97,9 +91,6 @@
- putcode( t_white[l].bit_code, t_white[l].bit_length );
- }
-
--#ifdef __GNUC__
--inline
--#endif
- void putblackspan _P1( (l), int l )
- {
- if ( l >= 64 )
-@@ -128,9 +119,6 @@
- putcode( t_black[l].bit_code, t_black[l].bit_length );
- }
-
--#ifdef __GNUC__
--inline
--#endif
- void puteol _P0( void ) /* write byte-aligned EOL */
- {
- static int last_buflen = 0;
-diff -U3 -r a/g3/pbm2g3.c b/g3/pbm2g3.c
---- a/g3/pbm2g3.c 1998-05-07 07:32:04.000000000 -0400
-+++ b/g3/pbm2g3.c 2018-01-13 22:38:11.742884611 -0500
-@@ -39,9 +39,6 @@
-
- static int out_byte_tab[ 256 ]; /* for g3 byte reversal */
-
--#ifdef __GNUC__
--inline
--#endif
- void putcode _P2( (code, len), int code, int len )
- {
- out_data |= ( code << out_hibit );
-@@ -59,18 +56,12 @@
- }
- }
-
--#ifdef __GNUC__
--inline
--#endif
- void puteol _P0( void ) /* write byte-aligned EOL */
- {
- if ( byte_align ) while( out_hibit != 4 ) putcode( 0, 1 );
- putcode( 0x800, 12 );
- }
-
--#ifdef __GNUC__
--inline
--#endif
- void putwhitespan _P1( (l), int l )
- {
- if ( l >= 64 )
-@@ -99,9 +90,6 @@
- putcode( t_white[l].bit_code, t_white[l].bit_length );
- }
-
--#ifdef __GNUC__
--inline
--#endif
- void putblackspan _P1( (l), int l )
- {
- if ( l >= 64 )
diff --git a/policy.patch b/policy.patch
index e098b978f8c2..5b72ad65d511 100644
--- a/policy.patch
+++ b/policy.patch
@@ -1,22 +1,8 @@
--- policy.h 2010-01-24 00:28:51.000000000 +0100
+++ policy.h.neu 2010-01-24 22:36:18.000000000 +0100
-@@ -564,14 +564,14 @@
- #endif
-
- #ifndef MAILER
--# define MAILER "/usr/lib/sendmail"
-+# define MAILER "/usr/sbin/sendmail"
- # define NEED_MAIL_HEADERS
- #endif
-
- /* where to send notify mail about incoming faxes to
- * (remember to create an mail alias if no such user exists!)
- */
+@@ -577,1 +577,1 @@
-#define MAIL_TO "faxadmin"
+#define MAIL_TO "root"
-
- /* after a fax has arrived, mgetty can call a program for further
- * processing of this fax.
@@ -586,7 +586,7 @@
* If you don't want this type of service, do not define it at all
* Absolute path name has to be used here!