summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-01-31 13:32:36 +0100
committertytan6522021-01-31 13:32:36 +0100
commit472b34f2c49e9315a4a73365ba6ee577682a301d (patch)
treec924e6b166f094c912e26861f81125c37ffd7071
parent14f569f199fa5cb17488e9f05a7594b7b892706d (diff)
downloadaur-472b34f2c49e9315a4a73365ba6ee577682a301d.tar.gz
build: update to 0.4.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d470a9164c14..c96d944ca98f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = obs-gphoto
pkgdesc = Allows connect DSLR cameras with obs-studio through gPhoto on Linux
- pkgver = 0.3.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/Atterratio/obs-gphoto
- arch = i686
arch = x86_64
license = GPL2
makedepends = cmake
depends = obs-studio
depends = libgphoto2
- depends = imagemagick
- source = https://github.com/Atterratio/obs-gphoto/archive/v0.3.0.tar.gz
- sha256sums = 33aa5c82caeaec7e6212019613a3d92e73f51431589ac1d6b3f851fa0b51295b
+ source = obs-gphoto-0.4.0.tar.gz::https://github.com/dunkelstern/obs-gphoto/archive/v0.4.0.tar.gz
+ source = obs-studio-25.0.8.tar.gz::https://github.com/obsproject/obs-studio/archive/25.0.8.tar.gz
+ sha256sums = c51645b9451c80ab426105f88c655ff11e228585cdd40bfc7b473e5d324b61aa
+ sha256sums = ef1179c23256c312212e3dce9083d4fa67751db05c3001ad824e2b6995943941
pkgname = obs-gphoto
diff --git a/PKGBUILD b/PKGBUILD
index 1a5f6f9becf9..1a08a9e79b4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,34 @@
-# Maintainer: Atterratio
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-gphoto
-pkgver=0.3.0
+pkgver=0.4.0
+_obsver=25.0.8
pkgrel=1
pkgdesc="Allows connect DSLR cameras with obs-studio through gPhoto on Linux"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/Atterratio/obs-gphoto"
license=("GPL2")
-depends=("obs-studio" "libgphoto2" "imagemagick")
+depends=("obs-studio" "libgphoto2")
makedepends=("cmake")
-source=("https://github.com/Atterratio/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=("33aa5c82caeaec7e6212019613a3d92e73f51431589ac1d6b3f851fa0b51295b")
+source=(
+ "$pkgname-$pkgver.tar.gz"::"https://github.com/dunkelstern/$pkgname/archive/v$pkgver.tar.gz"
+ "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
+)
+sha256sums=(
+ 'c51645b9451c80ab426105f88c655ff11e228585cdd40bfc7b473e5d324b61aa'
+ 'ef1179c23256c312212e3dce9083d4fa67751db05c3001ad824e2b6995943941'
+)
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- cmake . -DSYSTEM_INSTALL=1
- make
+ cd "$pkgname-$pkgver"
+ cmake -B build \
+ -DLIBOBS_INCLUDE_DIR=../obs-studio-$_obsver/libobs \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DSYSTEM_INSTALL=1
+ make -C build
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir}/ install
+ cd "$pkgname-$pkgver"
+ make -C build DESTDIR="$pkgdir/" install
}