summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-09-07 09:50:45 -0400
committerGuillaume Horel2021-09-07 09:50:45 -0400
commit475155b6abcaf2b1d91672e4f96fa3d7d28ab778 (patch)
tree718560a5610de13d44caf77cb76197ab44be19d0
parenta8f3eb69983a47917aad35e80cec443294e894b1 (diff)
downloadaur-475155b6abcaf2b1d91672e4f96fa3d7d28ab778.tar.gz
fix permission issues
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7dcb767337e..a53c76135cfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-scs
pkgdesc = Convex cone solver via operator splitting.
pkgver = 2.1.4
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/cvxgrp/scs/
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index f30692ca9a4d..e0aec989ee1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname='python-scs'
_pkgname='scs'
pkgver='2.1.4'
-pkgrel=1
+pkgrel=2
pkgdesc="Convex cone solver via operator splitting."
url="http://github.com/cvxgrp/scs/"
depends=('python' 'python-numpy' 'python-scipy')
@@ -21,6 +21,7 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
+ rm -rf scs.egg-info
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -D -m644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
}
@@ -28,5 +29,6 @@ package() {
check() {
cd "${_pkgname}-${pkgver}"
python setup.py build_ext --inplace
- pytest
+ cp src/__init__.py scs
+ PYTHONPATH=. pytest
}