summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2014-12-21 19:38:21 +0100
committerHyacinthe Cartiaux2015-06-09 14:09:40 +0200
commit47519f4e6f97da36d1c59604ca9ba6b29304ab3d (patch)
tree313f2b780b6d8005d07a73c385d4e977f9f0c456
parente4e37824e357229eec221e62757a6bbbe5db0c42 (diff)
downloadaur-47519f4e6f97da36d1c59604ca9ba6b29304ab3d.tar.gz
[powerstat-git] Update, guidelines compliance
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD47
2 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80a5038d3e55..bb0e22761bba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powerstat-git
- pkgdesc = a tool for measuring a laptops power usage via the battery
- pkgver = 20140207
+ pkgdesc = A tool for measuring a laptops power usage via the battery.
+ pkgver = 0.01.09.r123.g9d6e69d
pkgrel = 1
url = http://kernel.ubuntu.com/~cking/powerstat/
arch = i686
@@ -9,6 +9,9 @@ pkgbase = powerstat-git
makedepends = git
depends = glibc
provides = powerstat
+ conflicts = powerstat
+ source = git://kernel.ubuntu.com/cking/powerstat.git
+ md5sums = SKIP
pkgname = powerstat-git
diff --git a/PKGBUILD b/PKGBUILD
index 5d979b940caf..32fbf1b06e9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
-# Contributor: Eugeni Dodonov <eugeni@dodonov.net>
-
+# Contributor: Earnest <zibeon@gmail.com>
+# Contributor: Eugeni Dodonov <eugeni@dodonov.net>
pkgname=powerstat-git
-pkgver=20140207
+pkgver=0.01.09.r123.g9d6e69d
pkgrel=1
-pkgdesc="a tool for measuring a laptops power usage via the battery"
-arch=(i686 x86_64)
+
+pkgdesc='A tool for measuring a laptops power usage via the battery.'
+arch=('i686' 'x86_64')
url="http://kernel.ubuntu.com/~cking/powerstat/"
-license=(GPL2)
-depends=(glibc)
-makedepends=(git)
+license=('GPL2')
+
+depends=('glibc')
+makedepends=('git')
provides=('powerstat')
+conflicts=('powerstat')
-_gitroot=git://kernel.ubuntu.com/cking/powerstat.git
-_gitname=powerstat
+source=('git://kernel.ubuntu.com/cking/powerstat.git')
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd powerstat
+ git describe | sed 's/^V//; s/-/.r/; s/-/./'
+}
build() {
- cd ${srcdir}
- if [ -d $_gitname ] ; then
- ( cd $_gitname && git pull )
- else
- git clone $_gitroot
- fi
-
- rm -rf "${_gitname}_build"
- cp -r "${_gitname}" "${_gitname}_build"
-
- cd "${_gitname}_build/"
- make
+ cd powerstat
+ make
}
package() {
- cd "$srcdir/${_gitname}_build"
- make DESTDIR="$pkgdir/" install
+ cd powerstat
+ make DESTDIR="$pkgdir" install
}