summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdavidwu2022-05-15 22:26:34 +0800
committerxdavidwu2022-05-15 22:26:34 +0800
commit47636675da7814ee6fa1d5a7ab2b18692a7fc3a2 (patch)
treefcf390e037bb7eb42cc6884fab0590290a7f7d4d
parent854dcf1f4c711074e66f3cb674431ae395cd41de (diff)
downloadaur-47636675da7814ee6fa1d5a7ab2b18692a7fc3a2.tar.gz
18.0.1.1b2_openj9_0.32.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d0ef0a92d45..0fcbfb5abbd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdk-openj9-bin
pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk18
- pkgver = 18.0.1b10_openj9_0.32.0
+ pkgver = 18.0.1.1b2_openj9_0.32.0
pkgrel = 1
url = https://developer.ibm.com/languages/java/semeru-runtimes/downloads
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = jdk-openj9-bin
conflicts = jdk18-openj9-bin
conflicts = jdk18-openj9
options = !strip
- source = https://github.com/ibmruntimes/semeru18-binaries/releases/download/jdk-18.0.1%2B10_openj9-0.32.0/ibm-semeru-open-jdk_x64_linux_18.0.1_10_openj9-0.32.0.tar.gz
- sha256sums = 6e146103169c4e3173c8ce32c549daa8a979c6389bfc3b0b9248f1ecaf37f5ea
+ source = https://github.com/ibmruntimes/semeru18-binaries/releases/download/jdk-18.0.1.1%2B2_openj9-0.32.0/ibm-semeru-open-jdk_x64_linux_18.0.1.1_2_openj9-0.32.0.tar.gz
+ sha256sums = 708d7d7b5ac3c793f7fa9b045024276b54f973dcb833cccc0be697261884db4a
pkgname = jdk-openj9-bin
diff --git a/PKGBUILD b/PKGBUILD
index b9aab082db6a..2d1ac3a57659 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,10 @@ pkgname=jdk-openj9-bin
_jdkver=18
_jdkminor=0
_jdkpatch=1
-_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}
+_jdksubpatch=1
+_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}.${_jdksubpatch}
_openj9ver=0.32.0
-_buildvershort=10
+_buildvershort=2
_buildver=${_buildvershort}_openj9-${_openj9ver}
pkgver=${_jdkfullver}b${_buildver//-/_}
pkgrel=1
@@ -33,7 +34,7 @@ conflicts=("jdk${_jdkver}-openj9-bin" "jdk${_jdkver}-openj9")
options=(!strip)
source=("https://github.com/ibmruntimes/semeru${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
-sha256sums=('6e146103169c4e3173c8ce32c549daa8a979c6389bfc3b0b9248f1ecaf37f5ea')
+sha256sums=('708d7d7b5ac3c793f7fa9b045024276b54f973dcb833cccc0be697261884db4a')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9