summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2019-11-03 11:16:02 +0100
committerPopolon2019-11-03 11:16:02 +0100
commit476686b9f1689c5680f2e9c94dd3f68006ca9b13 (patch)
tree9972ffcdbd4a615754d572c3cf166cd78b8a7b19
downloadaur-476686b9f1689c5680f2e9c94dd3f68006ca9b13.tar.gz
Add .SRCINFO and PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..861ca49315cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = ibus-table-mongol-bichig-git
+ pkgdesc = An Input method for iBus to type traditional (uyghur) mongolian script
+ pkgver = git
+ pkgrel = 1
+ url = https://framagit.org/popolon/ibus-table-mongol_bichig
+ arch = any
+ license = WTFPL
+ depends = ibus-table
+
+pkgname = ibus-table-mongol-bichig-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e8ef40d4077
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Popolon <popolon@popolon.org>
+pkgname=ibus-table-mongol-bichig
+pkgver=git
+pkgrel=1
+pkgdesc='https://framagit.org/popolon/ibus-table-mongol_bichig'
+arch=(any)
+url='https://framagit.org/popolon/ibus-table-mongol_bichig'
+license=('WTFPL')
+depends=('ibus-table')
+makedepends=('ibus-table')
+source=("git+https://framagit.org/popolon/ibus-table-mongol_bichig.git")
+sha256sums=(SKIP)
+
+build() {
+ cd ibus-table-mongol_bichig
+
+ ./compile.sh
+}
+
+package() {
+ cd ibus-table-mongol_bichig
+
+ install -Dm644 mongol_bichig.db "${pkgdir}/usr/share/ibus-table/tables/mongol_bichig.db"
+ install -Dm644 mongol_bichig.svg "${pkgdir}/usr/share/ibus-table/icons/mongol_bichig.svg"
+}