summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-12-17 22:56:27 -0800
committerAndy Weidenbaum2015-12-17 22:56:27 -0800
commit47772f2721f032b1e6c92eb99c4533fe0a085fc2 (patch)
tree380741dcfa47a1ea6104d8ddcd929878819e9cbd
downloadaur-47772f2721f032b1e6c92eb99c4533fe0a085fc2.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67657a477a0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Dec 18 06:56:14 UTC 2015
+pkgbase = perl6-html-parser-xml
+ pkgdesc = Parses HTML to produce an XML::Document
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/tony-o/perl6-html-parser-xml
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = git
+ depends = rakudo
+ depends = perl6-xml
+ source = perl6-html-parser-xml-0.0.1::git+https://github.com/tony-o/perl6-html-parser-xml
+ sha256sums = SKIP
+
+pkgname = perl6-html-parser-xml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95725fa1d174
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-html-parser-xml
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Parses HTML to produce an XML::Document"
+arch=('any')
+depends=('rakudo' 'perl6-xml')
+checkdepends=('perl')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/tony-o/perl6-html-parser-xml"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/tony-o/perl6-html-parser-xml)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
+ find lib -mindepth 1 -maxdepth 1 -exec \
+ cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+}