summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjfperini2015-06-10 03:43:17 -0300
committerjfperini2015-06-10 03:43:17 -0300
commit478f63a1d2480df7bdb15d65076932fbde7aff5a (patch)
tree5eee0cecac671eba6af6cae873abfa56574a43bd
downloadaur-478f63a1d2480df7bdb15d65076932fbde7aff5a.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD62
-rw-r--r--meteo.install12
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eac509885ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = meteo
+ pkgdesc = Meteo es un proyecto de software libre que recopila datos meteorológicos para Radit.
+ pkgver = 1.0.2+r2.ea7996c
+ pkgrel = 1
+ url = http://www.radit.org/net
+ install = meteo.install
+ arch = any
+ license = GPL v3
+ makedepends = git
+ depends = qt4
+ source = meteo::git+https://github.com/jfperini/meteo.git
+ md5sums = SKIP
+
+pkgname = meteo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6725c1a6b423
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: jfperini <@jfperini>
+# Contributor: jfperini <@jfperini>
+
+pkgname=meteo
+pkgver=1.0.2+r2.ea7996c
+pkgrel=1
+pkgdesc="Meteo es un proyecto de software libre que recopila datos meteorológicos para Radit."
+url="http://www.radit.org/net"
+arch=('any')
+license=('GPL v3')
+install=meteo.install
+depends=('qt4')
+makedepends=('git')
+# provides=('')
+# conflicts=('')
+source=("$pkgname"::'git+https://github.com/jfperini/meteo.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+
+ cd "$srcdir/$pkgname"
+
+ # Use the tag of the last commit
+ printf "1.0.2+r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+
+build()
+{
+
+ cd "$srcdir/$pkgname/src"
+
+ msg2 " -> Build program..."
+ qmake-qt4 $pkgname.pro
+ make
+
+}
+
+
+package() {
+
+ cd "$srcdir/$pkgname"
+
+ rm -rf {.git,.gitignore,CONTRIBUTORS,COPYING,CREDITS,LICENSE.txt,README.md}
+
+ msg2 " -> Installing program..."
+ install -d $pkgdir/{opt/radit,usr/bin}
+ cp -a "./LinuxDesktop/$pkgname" "$pkgdir/opt/radit"
+ cp -u "./launcher/$pkgname" "$pkgdir/usr/bin"
+
+ chmod -R 775 $pkgdir/opt/radit/$pkgname
+
+ install -Dm644 "./launcher/$pkgname.svg" "$pkgdir/usr/share/pixmaps/$pkgname.svg"
+ install -Dm644 "./launcher/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # chmod -R ugo+rX "$pkgdir/opt"
+
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file
diff --git a/meteo.install b/meteo.install
new file mode 100644
index 000000000000..21f9139b41d1
--- /dev/null
+++ b/meteo.install
@@ -0,0 +1,12 @@
+
+ post_upgrade(){
+
+ echo ":::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::"
+
+ echo "Ejecutar nuevamenete el script: https://github.com/jfperini/radit/blob/master/radit.sh"
+
+ echo ":::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::"
+
+ echo "Gracias por actualizar Radit!"
+
+ } \ No newline at end of file