summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYardena Cohen2020-08-28 17:02:29 -0700
committerYardena Cohen2020-08-28 17:02:29 -0700
commit47999f434d88e0ed456192a8e02ce7d6c4b1dd60 (patch)
tree13b04e0187a9367f7fcfa1691aac89ecb94abe4f
parentf1959b1329ff04de8f597952850056f9abb0f5da (diff)
downloadaur-47999f434d88e0ed456192a8e02ce7d6c4b1dd60.tar.gz
new upstream
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bad4e3eb08c..b3e87b4818df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
# Generated by mksrcinfo v8
-# Sat May 23 21:59:37 UTC 2020
+# Fri Aug 28 23:39:33 UTC 2020
pkgbase = htop-git
pkgdesc = Interactive text-mode process viewer
- pkgver = 1079.17bad17
+ pkgver = 3.0.0.4.g2d14269
pkgrel = 1
- url = https://github.com/SoapGentoo/htop
+ epoch = 1
+ url = https://htop.dev
arch = i686
arch = x86_64
license = GPL
makedepends = git
makedepends = python
depends = ncurses
+ depends = libnl
optdepends = lsof: list open files for running process
optdepends = strace: attach to running process
provides = htop
conflicts = htop
options = !emptydirs
- source = git+https://github.com/SoapGentoo/htop.git#branch=fix-gcc10
+ source = git+https://github.com/htop-dev/htop.git
sha256sums = SKIP
pkgname = htop-git
diff --git a/PKGBUILD b/PKGBUILD
index a1069178bdeb..b76bd6b4bd01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,27 @@
gitname=htop
pkgname=${gitname}-git
-pkgver=1079.17bad17
+pkgver=3.0.0.4.g2d14269
pkgrel=1
+epoch=1
pkgdesc="Interactive text-mode process viewer"
-url="https://github.com/SoapGentoo/${gitname}"
+url="https://htop.dev"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('ncurses')
+depends=(ncurses libnl)
makedepends=('git' 'python')
optdepends=('lsof: list open files for running process'
'strace: attach to running process')
provides=('htop')
conflicts=('htop')
options=('!emptydirs')
-source=("git+${url}.git#branch=fix-gcc10")
+source=("git+https://github.com/htop-dev/htop.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${gitname}"
- local ver="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
- printf "%s" "${ver//-/.}"
+ cd "${srcdir}/${gitname}"
+ local ver="$(git describe --tags)"
+ printf "%s" "${ver//-/.}"
}
prepare() {