summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Plakhotniuk2015-06-23 15:21:03 -0500
committerOleg Plakhotniuk2015-06-23 15:21:03 -0500
commit47a688d5a9edc7c93063e2604c60af5501e21c61 (patch)
treeda3128dc840292fffa460bfbae85ea41221de342
downloadaur-47a688d5a9edc7c93063e2604c60af5501e21c61.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD28
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6662e2f44032
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by makepkg 4.2.1
+# Sat May 30 00:54:10 UTC 2015
+pkgbase = hinance
+ pkgdesc = Automated personal bookkeeping for hackers.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.hinance.org
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = haskell-pretty-show
+ depends = haskell-regex-tdfa
+ depends = python2
+ depends = weboob
+ source = git+https://github.com/olegus8/hinance#tag=1.0.0
+ source = https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css
+ source = https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap-theme.min.css
+ source = https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/js/bootstrap.min.js
+ source = https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js
+ md5sums = SKIP
+ md5sums = 3ab3438f85ad9f9e27e1af1facf0a9c4
+ md5sums = 95eb835999f0c2f1f3218d46e6c30137
+ md5sums = 2616d3564578d8f845813483352802a9
+ md5sums = 8101d596b2b8fa35fe3a634ea342d7c3
+
+pkgname = hinance
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f072cf4db01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Oleg Plakhotniuk <olegus8@gmail.com>
+pkgname=hinance
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Automated personal bookkeeping for hackers."
+arch=('any')
+url="http://www.hinance.org"
+license=('GPL3')
+depends=('haskell-pretty-show' 'haskell-regex-tdfa' 'python2' 'weboob')
+makedepends=('git')
+source=("git+https://github.com/olegus8/hinance#tag=${pkgver}"
+ 'https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap.min.css'
+ 'https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/css/bootstrap-theme.min.css'
+ 'https://maxcdn.bootstrapcdn.com/bootstrap/3.3.1/js/bootstrap.min.js'
+ 'https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js')
+md5sums=('SKIP'
+ '3ab3438f85ad9f9e27e1af1facf0a9c4'
+ '95eb835999f0c2f1f3218d46e6c30137'
+ '2616d3564578d8f845813483352802a9'
+ '8101d596b2b8fa35fe3a634ea342d7c3')
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "${pkgdir}"/usr/{bin,lib/hinance/www}
+ ln -s /usr/lib/hinance/hinance-daemon "${pkgdir}"/usr/bin/hinance
+ cp -t "${pkgdir}"/usr/lib/hinance/www "$srcdir"/{bootstrap,jquery}*
+ cp -r src/* "${pkgdir}"/usr/lib/hinance
+}