summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-11-18 03:43:38 +0100
committersL1pKn072023-11-18 03:43:38 +0100
commit47c0ffc7b1325ca42f7c607a56f95b798a4b112a (patch)
tree07940ea5cf62ecb6bf3d6182e3751706890e526a
parent4890e7476f31d7d0ecdfa1b653335f380364879c (diff)
downloadaur-47c0ffc7b1325ca42f7c607a56f95b798a4b112a.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae5584fa49db..417e938ac0d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ktorrent-git
pkgdesc = A powerful BitTorrent client. (GIT version)
- pkgver = 24.01.75.r3097.599f5a16
+ pkgver = 24.01.75.r3140.f3c8bd1a
pkgrel = 1
url = https://apps.kde.org/ktorrent
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = ktorrent-git
makedepends = python
makedepends = boost
makedepends = taglib
- makedepends = geoip
+ makedepends = libmaxminddb
makedepends = qt5-webengine
makedepends = phonon-qt5
makedepends = plasma-workspace
@@ -44,7 +44,7 @@ pkgbase = ktorrent-git
depends = karchive5
optdepends = plasma-workspace: for shutdown plugin
optdepends = kplotting5: for stats plugin
- optdepends = geoip: for infowidget plugin
+ optdepends = libmaxminddb: for infowidget plugin
optdepends = kdnssd5: for zeroconf plugin
optdepends = taglib: for mediaplayer plugin
optdepends = phonon-qt5: for multimedia plugin
@@ -52,6 +52,7 @@ pkgbase = ktorrent-git
provides = ktorrent
provides = libktcore.so
conflicts = ktorrent
+ options = debug
source = git+https://invent.kde.org/network/ktorrent.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9fd6c122d79c..e240e8e212a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=ktorrent-git
-pkgver=24.01.75.r3097.599f5a16
+pkgver=24.01.75.r3140.f3c8bd1a
pkgrel=1
pkgdesc="A powerful BitTorrent client. (GIT version)"
arch=('x86_64')
@@ -39,7 +39,7 @@ makedepends=(
'python'
'boost'
'taglib'
- 'geoip'
+ 'libmaxminddb'
'qt5-webengine'
'phonon-qt5'
'plasma-workspace'
@@ -49,7 +49,7 @@ makedepends=(
optdepends=(
'plasma-workspace: for shutdown plugin'
'kplotting5: for stats plugin'
- 'geoip: for infowidget plugin'
+ 'libmaxminddb: for infowidget plugin'
'kdnssd5: for zeroconf plugin'
'taglib: for mediaplayer plugin'
'phonon-qt5: for multimedia plugin'
@@ -63,6 +63,7 @@ provides=(
conflicts=('ktorrent')
source=('git+https://invent.kde.org/network/ktorrent.git')
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd ktorrent
@@ -70,12 +71,15 @@ pkgver() {
echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+prepare() {
+ sed 's|libmaxminddb|maxminddb|g' -i ktorrent/plugins/infowidget/CMakeLists.txt
+}
+
build() {
cmake -S ktorrent -B build \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
- -DBUILD_TESTING=ON \
+ -DBUILD_TESTING=ON
# -DBUILD_WITH_QT6=ON # NOTE: Qt6 port still unfinished