summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-02-24 22:32:20 +0100
committerMartchus2023-02-24 22:32:20 +0100
commit47d03bf03baf0a2c2883d3030be331922751fe88 (patch)
tree36476f799b86b559ac413e2ecc4a0fe5fc05fe60
parent254354b816d754a74b111cda755b3ca545c51673 (diff)
downloadaur-47d03bf03baf0a2c2883d3030be331922751fe88.tar.gz
Update pocketsphinx to 5.0.0
* Remove no longer required base package * Do not include Python module anymore; it is not built by default by the upsteam build script anymore (only if CMake variable SKBUILD is set) and thus supposedly designed to be distributed in a separate package; this makes also sense at it avoids rebuilding the C library on every minor Python release * Rebuild subtitlecomposer; however, at this point this means its speech plugin will not be available anymore as even the detection of the library does not work: ``` -- Could NOT find PocketSphinx (missing: POCKETSPHINX_INCLUDE_DIR) (found suitable version "5.0.0", minimum required is "5") -- Have NOT Found PocketSphinx - Speech plugin will not be built ```
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85accf8a2387..881bc97d516c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = pocketsphinx
- pkgdesc = Lightweight speech recognition engine
- pkgver = 5prealpha
- pkgrel = 13
- url = http://cmusphinx.sourceforge.net
+ pkgdesc = A small speech recognizer
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://cmusphinx.github.io
arch = i686
arch = x86_64
- license = BSD
- makedepends = swig
- makedepends = python
- depends = sphinxbase=5prealpha
- depends = gst-plugins-base-libs
- options = !libtool
- source = https://downloads.sourceforge.net/cmusphinx/pocketsphinx-5prealpha.tar.gz
- sha256sums = ef5bb5547e2712bdf571f256490ef42a47962033892efd9d7df8eed7fe573ed9
+ license = custom
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = gst-plugins-base-libs
+ optdepends = gst-plugins-base-libs: GStreamer plugin
+ source = https://github.com/cmusphinx/pocketsphinx/archive/refs/tags/v5.0.0.tar.gz
+ sha256sums = 78ffe5b60b6981b08667435dd26c5a179b612b8ca372bd9c23c896a8b2239a20
pkgname = pocketsphinx
diff --git a/PKGBUILD b/PKGBUILD
index 4414aa2ec95f..0333f16f0f68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,28 @@
# Contributor: Ben Duffield <bavardage AT archlinux.us>
pkgname=pocketsphinx
-pkgver=5prealpha
-pkgrel=13
-pkgdesc='Lightweight speech recognition engine'
+pkgver=5.0.0
+pkgrel=1
+pkgdesc='A small speech recognizer'
arch=('i686' 'x86_64')
-url='http://cmusphinx.sourceforge.net'
-license=('BSD')
-makedepends=('swig' 'python')
-depends=('sphinxbase=5prealpha' 'gst-plugins-base-libs')
-source=("https://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz")
-sha256sums=('ef5bb5547e2712bdf571f256490ef42a47962033892efd9d7df8eed7fe573ed9')
-options=('!libtool')
-
-prepare() {
- cd "$pkgname-$pkgver"
-
- echo "Reconfiguring project for current version of Automake"
- autoreconf -ivf > /dev/null
-}
+url='https://cmusphinx.github.io'
+license=('custom')
+makedepends=('cmake' 'ninja' 'gst-plugins-base-libs')
+optdepends=('gst-plugins-base-libs: GStreamer plugin')
+source=("https://github.com/cmusphinx/pocketsphinx/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('78ffe5b60b6981b08667435dd26c5a179b612b8ca372bd9c23c896a8b2239a20')
build() {
cd "$pkgname-$pkgver"
- export PYTHON=/usr/bin/python PYTHONWARNINGS=ignore
- ./configure --prefix=/usr
- make
+ cmake -S . -B build -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON -DBUILD_GSTREAMER=ON
+ cmake --build build
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ DESTDIR=${pkgdir} cmake --build build --target install
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"